MOD Devices Building More LV2 Plugins? (MOD Dwarf)

Interesting, they mention that it will be shipping with the Looperlative 2 Track Stereo Looper. Which is great because I just asked about an hour ago (Anyone seen a Stereo Looper?).

https://www.kickstarter.com/projects/modduo/mod-dwarf!

I am having a hard time finding out how to see if I can buy it and put it on MODEP though.

You can use sooperlooper stereo lv2 plugins too… https://mega.nz/file/2kx0SCAS#yrsvFP11nKQZdcBXwQFkWj0jxTf4dLLEzVpDaC0IzyE

1 Like

…and it’s out.

1 Like

So are you going to see have you can get them to work with Modep if i read the first post right?

1 Like

As a “community”, we could always try…

You can set up mod-plug-in-builder on Ubuntu 18.04(don’t use newer, it won’t work) and then build the new lv2 for modduo. Be warned that a lot of them require mod 1.10 and up to work…

1 Like

Both pieces of information are very useful!
A lot of Open Source work is about versions. Especially with Linux distress. Using the LTS version of Ubuntu, setting up MOD Plugin Builder, and making sure we’re using a recent version of mod.
Not completely sure what you mean about this last part (that building those LV2 require “mod 1.10”). Is it MPB 1.10? Not finding release numbers, though falkTX did mention 1.10 in February: https://github.com/moddevices/mod-plugin-builder/pull/104

Might actually go the Docker route. How To Use Docker Toolbox With MPB - MOD Wiki
Guessing it’ll be faster to build those on my M1 Mac than doing it on the Pi or on my Ubuntu laptop.

So modep is Mod 1.8, but the mod dwarf is running mod 1.11 already. Biggest change is the file handling which gives us IR cab sim and IR reverb. There are also some Neural net based drive pedals, like the chow centaur that sounds amazing!! If you’re keen to try mod 1.10, I have a script on my GitHub. https://github.com/micahvdm/mod

1 Like

Hey thanks for sharing this steps . I managed to get it working on 64 bit , just missing the lv2 effects , will check later why that is

I also built the lv2-example-plugin from sources but I get error when dropping it in the web UI

Speaking of MOD Dwarf…
This elaborate review gives me some ideas…

During the week, I did use MOD Plugin Builder (in Docker on my Mac) to compile a bunch of LV2 binaries which aren’t in the usual distribution of MODEP in PatchboxOS. I then copied those to my Pi and tried a few of them.
Sounds like things haven’t changed much on that front in the past few years. Some plugins work well, others don’t load. And, as discussed on occasion, there are issues with saving presets or snapshots.

As @deathbeard said, the MOD Dwardf uses a different version of the whole setup. Thanks for that screenshot, @DrKoma. Makes me realize that there are new features in the interface and those could be useful, including the “Manage CV Ports” part.

@Enkerli Its actually a super smooth version , runs much better in terms of UX and other things I guess .

I fiddled with it a bit and could get plugins displayed but only with a LOCAL red tag , and when dragging them into play they wont load . But dont consider this since it wasnt tested on Patchbox but on Raspberry OS 64 bit on a Pi 8 Gb ram with Pisound

I tried with building from sources a few lv2 and they do display but looking at the mod-host I can see "Plugin could not load " or similar . I tried in interactive mode with verbose but it did not make such a difference in output .

Hope to get it done some day with the help of the community

1 Like

Did you check the journalctl -u modep-mod-host -f when adding the plugin? Usually it’s some missing runtime dependency like some .so library. You may try running:

ldd /path/to/broken/lv2plugin.so

to see what libs it tries to load, and it might indicate missing ones too.

If you’re using aarch64 then you’ll need to build for modduox as it is 64bit. I am running mod 1.10 on patchbox with pi-stomp and it works great! You can only build modduo if you are running arm-v7 aka patchbox

Thanks , this 2 commands are useful . However , everything looks correct ? aarch64 etc , journal just reports “cant get plugin” wich is not much information to dig furher :frowning: :thinking:

1 Like

Ok , Ive got it working on a really strange way .
clone https://github.com/moddevices/mod-sdk
then running the server after installing it ./development_server.py
I can add many of my lv2 listed plugins and some come with the right interface for mod , some not , but can build it with them and adjust the UI as needed , after I can just send it to the localhost and its installed correctly and can add it .

The only strange thing left is that I cant connect patchcables to the mod-ui outputs, but since the fx show up in qjackctl I attach them to output from there . It works !

image

Its a bit tedious but encouraging to learn how to dive into all the layers of this thing . For now I can say that the web UI feels improved , and the audio is as good as usual using PiSound

2 Likes

jack-load modmonitor
That will get you connecting

1 Like

Awesome , the last version of mod-ui did the trick ! Thank you so much for the script . Im now just forced to build every needed plugin by hand with the mod-sdk and also there having some issues uploading to the board directly but getting it done manually

This would only be so if you are using aarch64 and not patchbox. If you’re using patchbox, then you can do a Modep setup and copy the lv2 folder to your local machine. These will all work on Mod 1.10 and that is what I have done. I even went and grabbed the mod lv2 data folder for mod devices GitHub to get the nice uis for most of the pedals

1 Like

Right , Im using Raspberry OS 64 . Testing jackd2 and a more powerful setup than I’ve tried before .