MIDIhub Editor will not connect

Hi. Just took delivery of my MIDIhub today. Trying to set it up. I already had 1.11.7 version of the Editor installed to familiarize myself.

Tried MIDIhub plugged into 2 different USB ports, tried plugging in then launching Editor, tried launching Editor then turning on MIDIhub, tried bootstrap mode (all lights on). Nothing worked. Each time I just get the blank Connecting window.

MIDIhub does not show up in any MIDI devices list in any software (Kontakt, AudioMIDISetup, Cubase…)

I noticed on the .dmg installer there is a license file. What is this used for?

Mac OS X 10.11.5


It’s a text file, mostly just the 3rd party library license notices.

Could you please place the Midihub Editor into the Applications folder, and start it like this from a Terminal, and try to connect with Midihub attached:

LIBSERIALPORT_DEBUG=1 /Applications/Midihub\ Editor.app/Contents/MacOS/Midihub\ Editor 2>&1 | tee mh.log

Then attach the mh.log produced in the Terminal’s current directory (your home folder by default, you can open Finder there just by running open . command.)

Thanks Giedrius

The mh log is attached

mh.log (13.0 KB)

Hey, looks like the device didn’t get enumerated by Mac OS. I’ll need more information, instructions below, please send it via a PM or by e-mail to hello@blokas.io:

  1. Restart your system with Midihub detached.
  2. Attach Midihub
  3. Do ‘About This Mac->System Report’ in the Apple menu, export all of the information into a file.
  4. Run these commands in a Terminal:
    sudo dmesg > dmesg.log
    tail -n 10000 /var/log/system.log > system.log
    ioreg -b > ioreg.log
  5. This will result in dmesg.log, system.log, ioreg.log files. If they end up being large-ish, please zip them up, the text files usually compress very well.
  6. Send those files together with the system report to us.

Further question - does the Midihub’s LEDs light up when connected to your Mac? Did you have a chance to test it out with any alternative host copmuter?


Thanks for the detailed instructions. Very much appreciated. I am familiar with Terminal so this should be no problem.

The light do come on when turned on. Press the button and it switches to preset 2 (I assume - light 2 illuminates). When turned on with the button held all lights are illuminated (bootstrap mode I believe?).

I have not tried with another host. I have an old MacBook Pro somewhere I can try.

Thanks for your efforts. I will report back with the log files.

1 Like


Attached are the requested log files. I hope these help. I rebooted, Connected the MIDIhub and turned it on, then ran the Terminal commands. I hope that was correct.


dmesg.log (16.0 KB) ioreg.log (239.3 KB)

and here is the system log

system.log (85.8 KB)

Ok, looks like there’s some issue with MacOS drivers and Serial Communication devices, first I noticed these errors in system.log:

Mar 16 00:08:20 DrOctoPro system_profiler[12524]: SPUSBDevice: IOServiceGetMatchingService did not return anything for location 0x00300000
Mar 16 00:08:20 DrOctoPro system_profiler[12524]: SPUSBDevice: IOServiceGetMatchingService did not return anything for location 0x00400000
Mar 16 00:08:20 DrOctoPro system_profiler[12524]: SPUSBDevice: IOServiceGetMatchingService did not return anything for location 0x00500000

Search of their meaning lead to this post:

Looks like Wacom Tablet driver (which seems to be present in system.log) can be interfering with other serial devices. The suggestion seems to be to remove 3rd party FTDI drivers. There’s more results on the internet, but no 100% solution that I could identify would work in all cases. This seems like some system / software misconfiguration error. Unfortunately as it does not occur on our Mac devices I can’t debug this quickly.

Before going on and removing drivers, first let’s find out more about the situation - have you ever installed some FTDI drivers or software like Arduino, etc, that may come packaged with some drivers?

Hi Giedrius

That is interesting. I read up on the FTDI mac issues, and it seems pretty par for the course for Macs; random problem that affects lots of users but not enough for them to address and fix.

Anyway, I found the FTDIKext.kext in /Library/Extensions and I found AppleUSBFTDI.kext in /System/Library/Extensions. So I assume I need to rm one of those (if not both??).

I wonder if having the WACOM installed but not active causes any issue? I unplug the WACOM tablet to make room on my desk for MIDI controllers. I’ll investigate removing the driver for it, it’s not a critical big deal to rm and reinstall if I have to.

I have a RaPi but have never connected it to the Mac. Most USB devices are plug and play system compliant so no drivers needed. The WACOM is about the only USB thing I have to install drivers for. There is the Behringer Neutron software, and perhaps AKAI MPX16. Thinking about it, all the music licensing apps; eLicenser, Arturia MCC, Native Instruments Service Center, etc etc. They all connect some software with some hardware.

I did find this article How to Fix FTDI Driver Issue on Mac and macOS - Alorium Technology and this discussion USB driver for serial comm (FTDI) - Apple Community that I’m following down the rabbit hole.

I shall report back.

Thanks again for your support.

1 Like

I’d suggest of course to just rename one of the files, so it’s easy to restore if it broke something or just didn’t help the situation. :slight_smile:

Yes indeed. I just mv out of that directory.

So far I was able to move the file in /Library/Extensions and remove the Wacom driver from the extensions. That did nothing.

To move the file in the System folder I need to turn off Apples advance security, which is a bit more of a process than I had time for this morning. I’ll try that later hopefully.

Hoping for better luck


Well I’m very sad to report that booting into Recovery Mode, disabling SIP, removing the AppleUSBFTDI.kext, rebooting, connecting MIDIhub, tried connecting…nothing. Just as before.

I also tried to install MIDIhub Editor on my old MacBook Pro, but it is on Snow Leopard, so it wouldnt work.

I have a boot drive of Mountain Lion around here somewhere. I can try with that.

I was really hoping one of the various things we tried would be a solution.

Did you try plugging in Midihub to see if it’d get recognized? (could be checked in Audio MIDI Setup if it appears there) This would help us know whether Midihub is indeed operating correctly, so there’s less possible variables in debugging this. :slight_smile:

Could you collect a new set of logs, using the same commands and steps as before after having done the various changes?

Hi Giedrius

I plugged MIDIhub into the MacBook Pro, looked in AudioMIDISetup and it didnt show up there. Also looked in the System Profiler and it didnt show up in the USB tree. Oh dear.

Attached is a new set of logs from the MacPro with the various kext’s removed.

Thanks for your continued attention

logs.zip (48.6 KB)

Was this the other Mac device? If it didn’t detect Midihub at all, it’d be really worth it to find some 3rd computer, maybe ask a friend for help, or maybe even just try a different USB cable. The Midihub does not require any special drivers to be installed, so any computer should immediately recognize it. Only Windows PCs requires a COM .INF file to be installed to work with the editor (it’s done by Editor’s installer), but even without it, it would still recognize the MIDI side of functionality.

This way we’d know if it’s not the cable or USB port fault. We haven’t ever yet encountered a bad USB port though.

I’ve taken a look at the logs, the original error messages are not there anymore, but the WacomTabletDriver is still active.

Which kexts did you rename? One of them (the one by Apple?) is still required for the serial USB communication to work.


I tried on my sons MacPro 5,1 model, but still has 10.11.6 just like me. He has the same FTDI kexts that I do, and a Wacom tablet installed. I didn’t want to mess around with his system so I didn’t rename any kext files. Anyway, the midihub did not show up in system profiler there either.

The kexts I renamed earlier were the 2 FTDI (FTDI and Apple versions) and the Wacom. I will do a full uninstall on the Wacom if it still showing as active. I had to return the Apple FTDI kext as my USB camera needed it, so I will rerun this logs with that installed.

I have access to a Windows PC I can try to hook it up to later. I doubt the cable is at fault. I plugged in another device into the same port on my Mac using the same cable and it shows up in system profiler.

Is there any way to determine if USB port would be faulty? Is that even possible from my end?


If it won’t get recognized by the Windows PC it might be it. It’s definitely strange that multiple Mac devices don’t recognize it. It should be visible under “Sound, video and game controllers” section in Device Manager.

The next time you collect the logs on Mac OS, please use ioreg -b -l > ioreg.log - one extra argument. :slight_smile:

Well, I’m really really disappointed to report it would not connect to very new Windows 10 PC. Exact same symptoms. Did not show up in the sound, video and game control panel either.

So, what now?


Ok, thank you for going through the efforts to close in on the issue - it does look like the USB port is probably faulty. Just to confirm - the Windows PC didn’t react to the plugging in of Midihub at all - no “installing device…” popup, no audio sounds it makes when a USB device is connected or removed? And when connected, Midihub played a spinning boot-up animation on its LEDs, and afterwards, an LED close to the USB connector is lit, as well as IN A LED is lit?

Please e-mail hello@blokas.io with your order details and we’ll arrange a replacement of the device under warranty. You’ll have to send the device and everything it came with back to us and we’lll ship you another unit.

Hi Giedrius

Yes that is exactly correct.

Well, I purchased the unit from a dealer, Forsyth Street Sounds in New York. I would have to return to them and have them arrange the replacement. I have let them know the situation and they assured me the device was brand new and never been used. I will let them know to get in touch.

Thanks again for all your help. I’m disappointed as I have been looking forward to using this for a very long time.