Midihub Editor on Raspberry Pi

I get a “This document is not a valid UTF 8” windows on trying to start 1.14.0 on my RPI Zero W with the Linux ARM image file :frowning:

It looks like it’s attempting to open it as a document. Did you do chmod +x ...? Try to start it from a terminal.

I tried chmod +x from the properties of the file as this worked on 1.13.4
As a noob I don´t know how to start from terminal :smirk:

(And I did a firmware update of the MIDIHUB and now the Transform pipe does not work anymore…hope to solve these problems once I can start 1.14.0)

This is an OS / UI issue - sometimes RPi tries to open programs as documents for me too, but anyway, to open it in a terminal, run these commands in a terminal window:

cd ~/Downloads
chmod +x MidihubEditor-arm_1.14.0.AppImage # Only needed once

Assuming, that you have downloaded it into your ~/Downloads folder. Otherwise, fix the path according to your local setup, or just download it again, run this command before chmod +x one:

curl -Ok https://blokas.io/downloads/MidihubEditor-arm_1.14.0.AppImage

seems to be executable now but I get a “memory access error”

so I guess I have to make a fresh install of PatchboxOS on a new SD card :face_with_raised_eyebrow:

(1.13.4 is still executable with errors in transform pipes -as I mentioned- but executable)

What is the output of lsb_release -a? The oldest supported target is buster.

No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 10 (buster)
Release: 10
Codename: buster

What is the output of:

./MidihubEditor-arm_1.14.0.AppImage --appimage-signature

The output is:
memory access error

I remember we’ve seen this before: [Download] Midihub Editor 1.11.10 & Firmware 1.11.11 - #14 by Giedrius

Since then my SD card where I used to make builds went corrupt and I had to rebuild the ARM build environment, probably it’s the same problem as it was before, I’ll look into it.

1 Like

I see: Same problem by the same person: Me :slight_smile:
Maybe its time for new hardware - RPI is back on a reasonable price :slight_smile:
By the way: Very big thanks for your help and your great developement of the midihub universe. I really admire the work of these young studied talented people (same on open source approach now on Deluge)

1 Like

Please give this build a try:


./MidihubEditor-arm_1.14.0.AppImage in console gives me:

QFontDatabase: Cannot find font directory /tmp/.mount_MidihuikdgPF/usr/lib/fonts.
Note that Qt no longer ships fonts. Deploy some (from https://dejavu-fonts.github.io/ for example) or switch to fontconfig.

so its starting a little slow, but it´s working. Big Thx for your help!!

1 Like

The QFontDatabase thing seems like just a warning, otherwise, everything seems to work. Let me know if you find some issues.

1 Like

same again with 1.14.1 unfortunately. Hope you can fix this again…can´t wait for the new clock pipe :+1:

Did you do the chmod +x on the file? Try starting it from the terminal.

1 Like

yes this worked. Thx a lot!

1 Like