Installing ableton link~ {solved}


#1

Hi,

I’m working on an installation which will make use of 4 pisound raspi with 4 puredata made sequencers sending midi notes and midi cc via the midi out of the pisound.
My problem is that I wanted to have them synchronized by using the abl_link~ external, but I couldn’t manage to install them.

Is there a specific method to install them so the patches will work right away and be in sync when starting them with the button ?
Is there a tutorial anywhere ?

I use the basic raspi system, an up to date pure data and pisound…

thanks !


#2

Hey! I just tried installing abl_link~ external for armv7 via deken, and it seems to work on my Raspberry Pi 3. I had to untick the ‘Hide foreign architectures?’ box for the plugin to be shown, see the attached screenshot. If you are using Raspberry Pi 2 or older, then armv7 might not work.

It’s nice to see @mzero’s name there by the external, who is a member of our community. :slight_smile:


#3

thanks a lot for taking the time.

it shows that my problem might be worst than I thought: I don’t have that preferences button on my dekken window… and I can’t update dekken to your version.

my understanding of all the linux stuff is too limited, so I’ll come back later on this post after doing a bit of linux homework.


#4

Sorry, I am using PD 0.49 version, we’ll share a build of it for Raspberry Pi with you soon :wink:

Anyway, I tried the same with 0.47 - I was able to get the armv7 version through the external finder as well, and it installed successfully.

Try installing the plugin while running as root - it will then install it to /usr/lib/pd/extra which is shared with all system users. Close all PD windows and start it by executing sudo puredata command, then go through with the install. :slight_smile:


#5

well yes that’s the problem: I have yet to find how to run as root :slight_smile:


#6

Start a terminal window, type in sudo puredata, and hit enter :slight_smile:

Everything you prefix with sudo, gets executed as root.


#7

it worked ! thanks a lot !


#8

Woot! Yay, glad it worked. For the record, I just built and published abl_link~ for the RaspberryPi - antlr did the hard work of writing it!