Impulse response plugin


I am really eager to have a impulse loader plugin. I searched for two days now without luck. I am really a Linux noob so if someone has a working plugin an explanation of how to install it would be really nice. i tried cabsim ir loader but it crashes on loading (GitHub - moddevices/mod-cabsim-IR-loader: Cabsim that can load Impulse Responses). I guess it is not compiled for the raspberry? I tried compiling it from source but thats over my head. I installed LSP impulse convolver but i cant get my head around the file handling. I really hope someone can help!

I have a raspberry pi 3 with patchbox os and modep 1.12


Does anyone have an idea?

@Mausero, we are working on plugin build tools and instructions for MODEP. Stay tuned. :wink:

1 Like

Thanks for your reply!

That’s great to hear, but as I suffer from an aggressive form of impatience, do you have any idea when? :crazy_face:

SSH onto pi, then run the following:
git clone GitHub - moddevices/mod-cabsim-IR-loader: Cabsim that can load Impulse Responses
cd mod-cabsim-IR-loader
cd source
sudo make install

Thanks for your reply!

I tried that but it said it was missing fttw3.h so I compiled fftw following this tutorial: Compile and install fftw on Raspberry Pi - Fear Cat
I compiled and installed it successfully but it didn’t make a difference. Still missing fftw3.h and sndfile.cp…

sudo apt install libsndfile fftw3-dev

Thanks deathbeard!
Had to install lv2-dev also and libsamplerate-dev
Now the plugin works :slight_smile:
But now i cant get the plugin to show up my IR files.
I uploaded them via the web file manager. I also tried putting them in the lv2 folder where the “Alice-in-Bones” wav is located.
Any suggestions?

Same here
no matter how I do it the IR files will never show in the drop down list of the loader :confused:
will keep searching

Can you check if there are folders in /var/modep? There needs to be a folder for each category in the file manager and I don’t see any script creating them…

1 Like

Yes I was able to upload the files using the file manager and I can see the file getting uploaded in /var/model/lv2/cabsim-ir_loader/
Exactly where the original file that comes with the plugin is
Checked the permissions also and seems ok
modep:modep but nothing is showing in the plugin except for the original one

Rebooted several times for other things but nothing

If someone finds a way to make it work please let us know

All the folders that are in the web file manager exist in var/modep/user-files
I uploaded a file via the web manager to the folder
Var/modep/user-files/Speaker Cabinet IR’s.
Hope I answered your question.

Ok, then the service is not pointing correctly…you’ll need to edit modep-mod-ui.service.
Needs to change to:

Mod-ui file manager is extremely temperamental

I tried your suggestion but still no luck :frowning:

You must have meant MOD_USER_FILES_DIR environment variable - it was missing in MODEP, we’ve fixed it in modep-mod-ui 1.12.0-5.

@Mausero, please revert your changes to MOD_DATA_DIR and update modep-mod-ui:

sudo apt update
sudo apt install modep-mod-ui

Thanks Giedrius,

That is really great to hear! I will try that when I have the time.

worked perfectly
thank you @Giedrius :slight_smile:


I just jumped a big hole in my ceiling!
Thanks for all the help.


So now that this seems to be working, where do you get files that can be used by ir cabsim?

I only use IR’s that I make myself from acoustic body’s like violins cellos etc (made with a contact Speaker and a sine sweep) I use them with my electric violin.
Here is a page with links to some free and paid IR’s

I haven’t used them myself