I/o audio error on PD


I am using Pisound, Rpi 3B+ and PD for a looper project. When I start the project I got this message “i/o audio error” and sometimes the Rpi is crashed and not responding untill I do the hard reboot (power supply)
Can you help please?

Does it print anything useful in the message window? Try starting Pure Data from a terminal, it may output additional information inside the terminal.

Hi @Giedrius I tried to run the PD -nogui and I got ‘watchdog: signaling pd’ messages. Sometimes the Rpi is crashed and not responding untill I do the hard reboot (power supply)

1 Like

I’ve done these following steps:

  1. run pd -nogui
  2. use UHC-1 micro SD (90 Mb/s Write)
  3. use rpi_zram. https://github.com/novaspirit/rpi_zram
  4. reduce the GPU to 16
  5. reduce the pisound from 128 to 64

I tried to start a new PD’s file and I got the same messages

Does this error occur with all Pure Data patches, or only this particular one?

I tried on a ‘blank’ pd file and it gives the same message and on another patches.

I’ve also done this on .sh:

connect ttymidi to pure data

(sleep 2.5

aconnect ttymidi:0 “Pure Data:0”

aconnect “Pure Data:1” ttymidi:1

aconnect -d ttymidi:0 pisound:0

aconnect -d pisound:0 ttymidi:1

aconnect -d ttymidi:0 pisound-ctl:0

aconnect -d pisound-ctl:0 ttymidi:1

aconnect -d pisound:0 “Pure Data:0”

aconnect -d “Pure Data:1” pisound:0

aconnect -d pisound-ctl:0 “Pure Data:0”

aconnect -d “Pure Data:1” pisound-ctl:0

) &

Are there any errors reported in dmesg?

Try also looking at the Jack backend log outputs:

sudo journalctl -u jack -f

I will send you the dmesg and jack backend log today.
I will also send you the log once it is crashed.
Thanks anyway

Hi @Giedrius
These are the logs of dmesg
and jack.
Thank you for helping me.

Looks like there’s no errors reported in dmesg, however, there’s something up in the Jack backend. The -f flag makes it print only the very latest messages and it keeps monitoring them in real time. In the attached log, it looks like this command was started only after the issue occurred and what happened prior to that is not available.

You may use:

sudo journalctl -u jack > jack.log

to get all available logs to a file, or just use the previous command and keep it running, before starting PD.

Btw, what are the contents of /etc/jackdrc file?

the jackdrc: https://drive.google.com/file/d/1nGPQhm71wvDaxm-qJJoGnD4jcCibpb9W/view?usp=sharing

the jack.log

The jack.log still contains limited amount of information, did you use > jack.log in the command?

sorry :slight_smile:

Still the same… :slight_smile: These new logs don’t show the error occurring. If sudo journalctl -u jack > jack.log does not provide any more information than what is attached, then try running sudo journalctl -u jack -f before reproducing the issue, then run PD, and attach the log when errors occur.

Ok I will remove the jack.log and run on terminal this:
sudo journalctl -u jack > jack.log

This command should write out all the log information it has for the Jack backend service. But if it keeps giving the same information as you’ve already provided, do this instead:

I got this message:
a lot of: patchbox jackdrc[408]: JackAudioDriver::ProcessGraphAsyncMaster: Process error

Try using bigger buffer size than 64, try 128, 256 or 512 and see if they keep the Jack from crashing.

Wow it helps! I use 256 BUT I got a lot of delays on another tracks (pd looper project)