Error Code: 3, impossible to flash new firmware

Hi, I have an error code 3 by flashing the new firmware with the new version of the software.
This is the first time with the Midihub. Nothing works.
BUT ! without doing anything and with the 1.11.2 version it seems to work correctly, but interface is different and no patchstorage compartiment ? Still, this is not the last version of the firmware, tough

I also tried with booting in bootloader mode with the button, after closing the software. Same issue.

I also tried the external firmware updater offline, different error message “Unexpected error while flashing the firmware”
with 11.11.8 and MidihubFw_1.11.10 :
same error : code -1 stage 8!

With the 11.11.7, the midihub seems to work. So it depends on the version of the software

I only use Windows 7 64 bit. No win 10

Thanks a lot

Hi, please use the latest editor and firmware available currently at [Download] Midihub Editor 1.11.10 & Firmware 1.11.11

  • First install the editor 1.11.10, and download the 1.11.11 firmware image
  • Start Midihub in bootloader mode (power it on while the button is held down, all LEDs should be lit up in this mode)
  • Start the editor
  • Connect to Midihub
  • Do Device->Flash Firmware
  • Point it to the 1.11.11 firmware file

Please let us know if the process succeeds, if not let us know what error it gives you. If it does succeed, try reconnecting to the device through the editor, let us know if it gives you any error at this stage.

Depending on the results, we’ll provide further troubleshooting steps.