[Beta] Patchbox OS image 2019-02-27 (Updated 2019-03-13)

#21

trying to port my btn scripts over to the new OS, having some hopefully basic issue with the button scripts no being picked up. Am pretty tired, so going to put this down and come back to it when I have some focus.

Set up was otherwise very smooth. the config screens really work nicely. Good work!

0 Likes

#22

Yeah, we had changed the default password to ‘blokaslabs’ in the 2019-03-13 image since the 2019-02-27 build, and it’s the only change we did between the versions. Here’s a quick summary of the passwords in each image:

2019-02-27 2019-03-13
User name patch patch
Password patch blokaslabs
WiFi SSID Patchbox Patchbox
WiFi password blokaslabs blokaslabs

Let us know how it goes! :slight_smile: Make sure all of the scripts have chmod +x done on them, so they are executable.

0 Likes

#23

OK, getting there :slight_smile: buttons working once i fixed the patch locations. doh! that’s what we you get for looking at this stuff last thing before bed. need to troubleshoot one or two missing externals, but otherwise all good. I’m testing pd through the x desktop, pd windows are out sized and difficult to navigate through VNC, maybe just change the font size or something…

0 Likes

#24

What is the resolution you are using in VNC? I haven’t noticed any issues with how PD looks, I used 1920x1080 and 1280x720.

0 Likes

#25

I also noticed that I the window size was very small, 300 pixels wide initially or so, had to change it afterwards. All fine but was just worried as I didnt see it in the instructions
cheers anyway great stuff

0 Likes

split this topic #26

5 posts were split to a new topic: Patchbox and ORAC

0 Likes

split this topic #30

5 posts were split to a new topic: Home WiFi not found

0 Likes

#31

Hi, when trying to change the hotspot settings using pisound-config i get an error, i’m running patchbox os 2019-03-13:

patch@patchbox:~ $ sudo pisound-config
Traceback (most recent call last):
File “/usr/local/pisound/pisound-config/main.py”, line 152, in
loop.run()
File “/usr/lib/python2.7/dist-packages/urwid/main_loop.py”, line 278, in run
self._run()
File “/usr/lib/python2.7/dist-packages/urwid/main_loop.py”, line 376, in _run
self.event_loop.run()
File “/usr/lib/python2.7/dist-packages/urwid/main_loop.py”, line 682, in run
self._loop()
File “/usr/lib/python2.7/dist-packages/urwid/main_loop.py”, line 719, in _loop
self._watch_filesfd
File “/usr/lib/python2.7/dist-packages/urwid/raw_display.py”, line 393, in
event_loop, callback, self.get_available_raw_input())
File “/usr/lib/python2.7/dist-packages/urwid/raw_display.py”, line 493, in parse_input
callback(processed, processed_codes)
File “/usr/lib/python2.7/dist-packages/urwid/main_loop.py”, line 403, in _update
self.process_input(keys)
File “/usr/lib/python2.7/dist-packages/urwid/main_loop.py”, line 500, in process_input
event, button, col, row, focus=True ):
File “/usr/lib/python2.7/dist-packages/urwid/decoration.py”, line 905, in mouse_event
event, button,col, row-top, focus)
File “/usr/lib/python2.7/dist-packages/urwid/decoration.py”, line 666, in mouse_event
focus)
File “/usr/lib/python2.7/dist-packages/urwid/container.py”, line 1169, in mouse_event
event, button, col, row-htrim, focus )
File “/usr/lib/python2.7/dist-packages/urwid/listbox.py”, line 1568, in mouse_event
focus)
File “/usr/lib/python2.7/dist-packages/urwid/wimp.py”, line 557, in mouse_event
self._emit(‘click’)
File “/usr/lib/python2.7/dist-packages/urwid/widget.py”, line 464, in _emit
signals.emit_signal(self, name, self, *args)
File “/usr/lib/python2.7/dist-packages/urwid/signals.py”, line 264, in emit
result |= self._call_callback(callback, user_arg, user_args, args)
File “/usr/lib/python2.7/dist-packages/urwid/signals.py”, line 294, in _call_callback
return bool(callback(*args_to_pass))
File “/usr/local/pisound/pisound-config/main.py”, line 95, in hs_menu
items = values.get_hs_config()
File “/usr/local/pisound/pisound-config/values.py”, line 90, in get_hs_config
with open(settings.HS_CFG, ‘r’) as f:
IOError: [Errno 2] No such file or directory: ‘/usr/local/pisound/scripts/pisound-btn/hostapd.conf’

0 Likes

#35

Thanks, that fixed it x

1 Like

#36

Yay!
Got started with this image, today. Sounds quite promising. Would be just plain delighted if it worked with mec-app!
Several cool packages want to install jackd even though it’s already installed. Is it likely to cause problems if I install it from Synaptic?
At this point, I’m mostly trying to play with LV2 plugins (as on Modep) in LMMS and/or Carla.
Chances are that I’ll also having some fun in Pd as it’s been a while. Maybe it’s just an impression but it sounds to me like there are more Pd-related packages than before (including in other distros).

0 Likes

#37

Yes, we’re using jackd2 package which is a more up to date one. Could you let me know which package you intend to install? I can take a look if it’s possible to simply swap the dependency for jackd2, or is there something more needed.

0 Likes

#38

There’s quite a few. I’ve successfully avoided them, but they’re somewhat tempting.
I’ll try to draw a list. For some reason, it’s also been difficult to get this specific distro to work with my HDMI screen (as opposed to my previous Raspbian image which does work appropriately).

0 Likes

#39

Try comparing the HDMI settings in /boot/config.txt of both installs. Also, make sure the HDMI cable is connected before powering on the Raspberry Pi.

1 Like

#40

Hmm… Dunno what it was, last night, but it’s working now (and the config.txt files in both installs are the same).

As for the Jack apps, here are some which depend on jackd (though they’re not jack-specific)…

  • ardour
  • din
  • freewheeling
  • kluppe
  • laborejo
  • phasex
  • qmidiarp
  • tractor

Also:

  • aeolus
  • composite
  • yoshimi
  • zynadd
0 Likes

#41

Is the usbmount package not installed by default with PatchboxOS?

(I had to manually install it just now, but I’m not sure if that’s due to some user error on my part)

Seems like this would be super helpful for dealing with patch loading from USB drives.

EDIT:
FWIW - to make usbmount work for me, I needed to do the following:

Edit /lib/systemd/system/systemd-udevd.service and change the line
MountFlags=slave
to
MountFlags=shared
0 Likes

#42

Patchbox OS is based on Raspbian Lite, with audio packages added on top, as well as some config tweaks. Suggestions of what to include are welcome, we’ll note this down for the time we’ll be building a new version of the image. :slight_smile:

1 Like