Audacity and New Mono Track Recording with Monitoring?


#1

Hello Everyone, I am loving the Pisound! It is Brilliant. Now question. When recording a new track in Audacity, I turn on the option Software Playthrough so I can Monitor what I am Recording using the PIsound output. I turn off the default option to overdub and monitor, I hit record and Audacity begins recording then stops anywhere from 6 to 16 seconds. I played with the buffer setting in audacity record pref.

How should I be monitoring new tracks using Pisound and Audacity version 2.1.2?

Any ideas?

Maybe I should’t need to monitor but it is a handy feature, lol


#2

Hey, I was able to reproduce this issue, however, I didn’t yet find a workaround. I can’t see any error getting logged by Audacity on this situation, so it’s not making this easy. :slight_smile: I’ve also tried building version 2.2.2 of Audacity from source, but it still has the same issue. Another thing I plan to try to is to configure a build with JACK backend enabled - software using JACK usually does better than using ALSA directly. I’ll let you know how it goes, getting this right takes a while…


[Solved] No audio input going to output
#3

Thank You for trying to get a solution, I know that the overdub option on secondary tracks allows monitor without an issue. So maybe the answer is to just record a click track on the First track. No reason to monitor that anyway. I guess I am just old school. It is probably a bug in audacity anyway, that is my guess.


#4

Hey! I just tried installing latest Raspbian Desktop (2018-10-09) build, and Audacity seems to be back to normal!

It may be enough to do the sudo apt-get update and sudo apt-get upgrade, but in case that doesn’t fix the issue, try the new build on a spare SD card.

Just in case, the kernel version that came with the OS image is 4.14.71-v7+