Amidiauto install error

When I try to run
sudo apt-get install amidiauto

I get an error
E: Unable to locate package amidiauto

I am on buster on Raspberry pi…

any idea?

thank you

You have to setup our APT server to access amidiauto package, see:

Well that link doesn’t work…

How to setup the server?

I installed Amidi and if a run systemctl amidiauto

it says failed in RED…

then if I run Amidi it works but it doesn’t run in background or autostart

Screen Shot 2020-05-08 at 14.50.11

curl | sh

That’s odd, but yes, it just shows the command as @everNoob posted.

Do you get any error when installing amidiauto? What does sudo systemctl status amidiauto say?

it says this

Same here, and I am really near to burry my dreams to aconnect my synths on my raspberry zero w

I ve tried everything for hours and I can connect on aconnectgui, but it is just again that frustrating experience of my life: There are WIN people, not studied, just buying all that smart things from studied Linux developpers, who honestly are trying to help, but the basics are not existing and will never exist:
Have you ever seen a user copy and pasting scripts and what ever it is called from a helpful community site to his command window (which of course runs in GUI) four hours and hours tryin to make things work and then he is happy to find out by himself that he has to close an editor with ctl+x and other things with ctl+c.
It is so frustrating, I bought this Midihub, which is such a great product, subscribed to this community just to find out that, if I want to get a simple midi routing on my raspberry to keep it all dawless, I fail and I will ever fail. Giedrius, you are such a kind and helpful person, but it must be frustrating for you and your team as well to see, that your genious product is used by noobs like me, annoying you with problems that are far beyond your skills. And than there are other people (like mzero or technobear for example) that really speak your language and give you progress, I really admire them…
This is just my thougts on realizing not to have made any music for days instead sorting out my problems on my Pi.
There is a solution to connect my synths via Pi, I know that, as fast as my Midihub does it (less than seconds) but I am damned for the future to do the little rest of external USB by booting my WIN 10 and load my MIDI OX…(sorry completly of topic)

Thank you for the kind words on Midihub. :slight_smile:

Just ask the right questions and we or someone will help you achieve your goal. :slight_smile: Please just create a dedicated thread for the problem you’re facing, provide the details, and we’ll help you get there.

When answering questions or providing guides, to keep the steps concise we must assume some prior knowledge on users to know how to implement these steps. Writing or even linking how to use text editors each time a file needs to be edited (and files do need to be edited a lot on Linux) would be excessive and detrimental to highlighting the actual things that must be done.

Of course everyone is free and welcome to ask for more detailed steps or some short guides, etc…, and we’ll help. :slight_smile:

So what can I do when sytemctl status amidiauto says: Active:failed

I did start/stop and enable/disable…

As we’re looking into adopting amidiminder by default on Patchbox OS, let’s continue here: Amidiminder problems NDLR MIDIHub