Wi-fi hotspot suddenly stopped working


yesterday i used the triple-click wi-fi hotspot for the first time without problems, including using vnc, but today i cannot start hotspot anymore. I did not change anything since yesterday, just the wifi network on which I was connected out of the hotspot mode. Today i tried to solve this by upgrading pisound packages (with “curl https://blokas.io/pisound/install-pisound.sh | sh”), but without success.

Which log should I look at? Is this problem known? Any hints to solve this?

Thanks a lot.

See the following reply by rbn, maybe it is the same issue: Pisound Triple-Click WiFi!

Thanks for the quick response!

I made the suggestion, deleting the contents of the network field in the file /etc/wpa_supplicant/wpa_supplicant.conf - this did not solve the problem.
If I try to run /usr/local/pisound/scripts/pisound-btn/enable_wifi_hotspot.sh manually, I get the following messages in the terminal:

sending commands to master dhcpcd process
ifdown: unknown interface wlan0

If there’s anything else I can do, please let me know.

What is the output of ifconfig? What Raspberry Pi version are you using?


I’m using a raspberry pi 3 with raspibian stretch. I ended up reinstalling the operating system because I needed this running today. After the reinstall process, everything worked, but you always have to delete the contents of the file wpa_supplicant.conf if you set up a wi-fi connection, otherwise the triple click does not work.

If I can reproduce the problem again I will post here the ifconfig output, or other necessary data.

Thank you very much for your attention and congratulations for the work.

Thank you, we will note this issue and see whether we can make it smoother.

1 Like