Using alsa_in alsa_out with two similar usb soundcards

Im a big fan of Modep, using it with an ESI MAYA 44 USB Soundcard for a long time now. Lately I ran short on inputs and tried to use alsa_in to connect a second MAYA44 (got a bunch of them laying around).

The cards show up like this with aplay -l:

card 3: USB [MAYA44 USB], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 4: USB_1 [MAYA44 USB], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Alsa_in was started like this:

alsa_in -j capture2 -d hw:CARD=USB_1 -c 4 -r 44100
alsa_in -j capture2 -d hw:CARD=USB_1,DEV=0 -c 4 -r 44100

it shows up in patchage as an input device and i can patch it somewhere, the inputs will however not show up in mod-ui, not even if i stop and restart with:

sudo systemctl stop modep-mod-ui
sudo systemctl start modep-mod-ui

Additionally if i try to create an alsa_out client i get

alsa_out -j playback2 -d hw:CARD=USB_1 -c 4
Unable to set hw params for playback: No space left on device
Setting of hwparams failed: No space left on device

I am very thankful for any hints as i would love to see these cards working in tandem. They are so cheap, small and light to integrate in a setup. I was even phantasizing about hacking the hardware to make them share a single Xtal so my raspi has no need to compensate for clock drifts. But now i am back to reality since i am already struggling with these simple first steps :frowning:

Anyone got similar brand/type usb dacs working in tandem on patchbox os ?