Update firmware not successful

I just got the Midihub and attempt to update the firmware. Followed the instruction and downloaded 1.11.4 and went thru the process. At the end of the process it keeps showing the error “Unexpected error occurred while flashing the firmware”. Now when I turn it off and on it is in the upgrade mode with all the light on.
Please help
Thank you

I have tried the news Editor 1.11.3 and the new firmware 1.115 This time it gives a different message “Unexpected error occurred while flashing the firmware, code-1, stage01” I am on a Mac OSX Mojave.


Just to put it out there I think Midihub is sensitive to the computer. I was having trouble in my 2011 Mac Pro. I pull out my 2018 MacBook Pro and using 1.11.2 editor and was able to update the 1.11.4 firmware. I than use the same setup and was able to use the 1.11.3 editor and update the firmware to 1.11.5 and I was able to do the patching in the MacBook Pro
I than plug it into the 2011 Mac Pro and it works for about 3 mins that it will be disconnected from the editor and I have to reconnect. Within 3 mins it will disconnect again.


The disconnection happens when the communication ‘times out’, this is controlled by the USB driver of the host OS. So far we haven’t encountered a system that would disconnect as often as on yours, we’ll try increasing the allowed response time.

Is there some high CPU usage on the system while this happens?

Not at the time. It’s has something to do with the driver like you said. I have an add on usb 3 card installed on this Mac Pro when I plug the Midihub to this port it worked flawlessly.