Unexpected error code -1, stage 8

Hi there. I’m unable to flash the latest firmware to Midihub. In fact, I’ve not actually been able to use it at all yet - I got this on pre-order so I assume it’s one of the first models, but have only just gotten around to incorporating it into my set up.

I’ve tried this with Editor version 1.12.2. I get the same error code when using firmware version 1.11.11 and 1.12.0. I’m not sure what to do.

The device shows up in my DAW, it just doesn’t seem to want to actually do anything. EDIT: …well, it DID show up in my DAW at one point but no longer seems to.

There doesn’t seem to be any driver error in device manager (Windows 7). The USB seems to connect properly. I’ve tried it in different ports and allowed it to reinstall correctly there. Still nothing.

Any advice would be much appreciated, thank you.

On Windows, most software, including DAWs, must be restarted after plugging in MIDI devices in order to react to devices that just appeared.

Try doing this:

  1. Start Midihub in bootloader mode by powering it on while holding the button pushed down. All LEDs should be lit up in this mode.

  2. Connect with the latest version of the editor.

  3. Download the firmware file.

  4. Do Device → Flash Firmware… and open the firmware file just downloaded.

It should bring Midihub’s firmware up to date and should allow the Editor to work with it.

If there’s any issues or errors along the way, please let me know exactly what you’re seeing. If issues still persist, it’d be helpful to see how Midihub appears in the Device Manager, make sure ‘Sound, video and game controllers’ and ‘Ports (COM & LPT)’ sections are expanded, it’s where Midihub should appear.

Thanks for the reply! Yeah, perhaps I should have said, I’ve tried restarting and repeating the process several times already. This gif is recorded after a fresh install of the editor and a restart, following the steps you listed. Have also included screenshots from my device manager. It doesn’t seem to appear in the “Sound, video, and game controllers” section, but it is in “Ports (COM & LPT)”.





I meant that most MIDI software has to be restarted every time you plug in new devices on Windows. So make sure that first you plug in Midihub and the rest of the devices, and only then start the DAW.

This flashing error 8 happens at the very final step, when asking Midihub to restart itself into the firmware mode. I don’t know why that would fail yet, but other than that, the new firmware should have been flashed correctly, and after manually turning Midihub off and on, it should be running firmware 1.12.0.

So the firmware upgrade seems to be done, and for now we should focus on getting it properly recognized on your PC, while Midihub is running in regular mode.

Are there anything in the ‘Other Devices’ section when it’s plugged in?

Any chance you could try connecting it to another computer and see if it manages to recognize it properly?

For every major OS, it should work right away, no drivers are necessary. For Windows that are older than Win 10, the MIDI side should work without any additional drivers, the COM requires an .inf file to be installed, that is done during Midihub Editor installation.

It’s not listed in “Other Devices”, no - I believe it is coming up as “USB Composite Device” - here is a GIF of me switching MIDIhub on and off whilst in Windows 7’s device manager. JpcE97c1pr

I’ve finally got it reliably sending MIDI from input A to my computer via USB, and it appears to be able to send MIDI over output A to a hardware synth as well, but that’s it - although the lights flash in time to incoming signals, and the MIDI Monitor displays the appropriate input, but nothing goes to or from any DAW or standalone plugin unless it’s in A. That is to say, B, C, and D all light up but no-one is home.

For the moment, I’d just love it to work as a 4 in 4 out USB interface. I assumed my own set up here would work…

…and cross-referencing with the preset on Patch Storage that seems to be the right idea.

But neither my own attempt nor the one on Patch Storage can convince anything other than the MIDIHub and the editor that MIDI is coming in or out on the other channels.

Do you think using a Windows 10 device to flash the firmware to the latest version would help? I could go to an internet cafe or something and try it; but really I need this to work in Windows 7 - and it would be such a hassle to do every time there’s an update.

I’ve noticed a lot of people have similar issues like this, but they all seem to work themselves out (often without providing any details as to how), I am still stuck!

Thanks for all your time and effort.

The firmware should be alright. Midihub is supposed to appear as a COM device, a USB composite device, and a Sound device. Maybe it’s the “USB Audio Device” in your previous screenshot? You could try inspecting the device, going through various properties, to find manufacturer or product strings.

If your Windows 7 installation does not recognize the Sound/MIDI part of the device properly, it means there’s some issue with Windows 7 drivers.

Btw, for debugging purposes, you could give MIDI-OX a try and check what it sees when Midihub is plugged in. (Options → MIDI Devices…)