Trouble Installing MODEP Module

I just installed the latest version of Patchbox OS on my Raspberry PI 3B+. When trying to install the MODEP module using the wizard it says Oops! Something went wrong. I tried installing the module from the Patchbox Configuration Utility this error shows:

org.freedesktop.DBus.Error.FileNotFound: No such file or directory
Manager: ERROR: org.freedesktop.system1.NoSuchUnit: Unit file modep-touchosc2midi.service does not exist.
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/patchbox/”, line 130, in enable_unit

The error message continues further from there. It seems like it can't find any of the resources required to install the module. Any tips?

Try installing modep-touchosc2midi manually, and try activating the MODEP module again:

sudo apt update && sudo apt install modep-touchosc2midi
1 Like

I had the same problem and your solution worked, but then I ran into “modep-mod-ui” not existing error, but was able to solve it by doing sudo apt install modep-mod-ui.

Did you first allow Patchbox to be updated, before installing MODEP? The original Patchbox OS image contained a bug where in case module installation fails for any reason (sometimes as simple as no internet connection being available), it’d treat installation as success anyway, leading into these issues. It is already fixed, so it’s a good idea to perform the update after flashing the OS image, by running:

patchbox update

or just doing the update when asked during the initial setup wizard.

Yes, I updated after flashing the card with the OS.