Supercollider 3.9


#1

Hi Folks

I just updated my pisound to stretch [finally] and i built Supercollider 3.9 from source
When i run SuperCollider it emits sound from the Headphone mini output
How do i direct it to come out of pisound?

Pd is working perfectly @ 96Khz from Pisound so i would love to test SC3.9 this way too
It seems like Jack is grabbing it and sending it out System but system seems to b the default Änalog out

Any idea?


#2

hi
i found the problem
I think i had made changes to my .jackdrc and a simple change from

/usr/bin/jackd -P3 -dalsa -dhw:0 -r44100 -p1024 -n3

to
/usr/bin/jackd -P3 -dalsa -dhw:1 -r44100 -p1024 -n3

did the trick


#3

I’d suggest to use -r48000 to avoid any resampling. :slight_smile:


#4

@Giedrius can you also suggest the best values for -n and -p? :slight_smile: On some USB interfaces you have to use odd number of periods so your latency is aligned to 1 millisecond. Does pisound have any similar quirks?


#5

Hey, we used -p 256 -n 2 for MODEP image. There’s no special alignment requirements from our side. :slight_smile: I think you should find the smallest values that still provide stable playback and recording for your use cases, it depends on the complexity of the audio processing.


#6

I tested yesterday all day and the sound is AMAZING with the pisound and 3.9. I was running a TON of Gendys and i think i finally got up to around 9% :slight_smile:

Does anyone have a lead on BBCut2?


#7

i will share that i had to upgrade packages to use gcc6 gcc4.9 was throwing errors and now everything is playing well


#8

Hi, thanks for this solution…

i use this line in the terminal:
/usr/bin/jackd -P3 -dalsa -dhw:1 -r44100 -p1024 -n3

after that i use supercollider with the pisound perfectly,

but now i want to run supercollider at boot and im having some problems…

im using this:
https://supercollider.github.io/development/building-raspberrypi.html

the autostart section:

nano ~/autostart.sh #and add the following lines (ctrl+o, ctrl+x to save and exit)…

#!/bin/bash
PATH=/usr/local/bin:$PATH
export DISPLAY=:0.0
sleep 10 #can be lower (5) for rpi3
sclang mycode.scd


i think that a posible solution to ru SC at boot and configure the pisound was adding the:
" /usr/bin/jackd -P3 -dalsa -dhw:1 -r44100 -p1024 -n3 " befor sclang… but is not working…

when i sue this line , after that i cant write another lines in the terminal…

how can i solve this problem?
Thanks :slight_smile:


#9

Add a ‘&’ at the very end of the line, that causes it to be executed in the background.

Also, use -r48000 sampling rate with Pisound, as its native sampling rates are 48kHz, 96kHz and 192kHz.


#10

Thanks! its working perfect now :slight_smile:


#11

sweet solution this is aweome so now we can have SC run all by itself


#12

Is it possible to make the 3.5mm output jack and the 1/4" stereo jack output work simultaneously?


#13

This seems relevant: https://github.com/redFrik/supercolliderStandaloneRPI2/wiki/multiple-usb-soundcards

Just use Pisound and default BCM audio card for outputs.


#14

Yes, you can and i do – installing the Pisound does not mean you have to disable the onboard sound
i use the onbaord when i am sampling from the Web and running the output into pisound for fun results
I just use an 1/8th inch cable to 1/4 inch for Pisound/Pd/Sc3 input and it works dreamy


#15

Sorry for too many novice questions, and admin please remove this if it’s not the right place to ask.

I installed SC according to this tutorial: https://supercollider.github.io/development/building-raspberrypi

I have some scripts for MIDI things, which didn’t work right out and realized the Jack sever didn’t save my MIDI patch bay settings, I have to disconnect all on patch bay and reconnect accordingly every time I turn on the Pisound.

How to save the patch bay settings on Jack Server? All I wanted is MIDI din-5 IN to SC, and SC to MIDI din-5 OUT.

Thanks all for helping me out!


#16

Somehow I am managed to do it by running aconnect xx:x xx:x on ALSA side at autostart shell. Although the port numbers are messy but did the trick.