Startx not possible

Hello all,

I’m a total newbie to this wonderful device, so I’m sure I’ve done something wrong.

I have worked through all the online documents several times and read many forum posts, but somehow it still doesn’t work.

I am connected to termius with the pisound. but unfortunately startx does not work. this is a screenshot from the terminal.
can anyone help me?

if you’re logged in through SSH then you can’t run the “startx” command. At least that’s what I have experienced. You’ll need to hook up your RPi to a monitor and attach keyboard/mouse. Once you do that you should be able to run startx. I would also suggest to configure Patchbox to start the desktop environment automatically. Then you can use RDP or VNC to access the GUI remotely.

thank you for your reply!
i will check it out!

It does work on my Pi to have default boot target as console login screen, running startx when ssh’ed just works. But in case it doesn’t, setting the boot target to one of the Desktop options should help avoid having to use startx in the first place.