Startx does not open desktop

Hi
I have some probs with my Zero W, which started when I tried to install NDLR Librarian that was for Linux not for Pi.
Now I want to make the faults undone step by step.

Actual Problem:
startx from console gives me
exec: /usr/bin/X: not found
xinit giving up

and sudo nano /boot/config.txt gives me an empty file

any help very much appreciated since this was my midihub core in my synt setup…til yesterday

Try sudo apt install --reinstall raspberrypi-ui-mods gnome-themes-standard-data gtk2-engines.

Original contents of config.txt and cmdline.txt are here:

On the other hand, it could be quicker to backup and start from a fresh SD card and install the software back. :slight_smile:

I did a fresh intall, now I am on Lxde Environment but ok, it works again.
Any way to reinstall the patchbox desktop environment?

Do you mean you flashed the SD card with Patchbox OS image? It should be there by default. Or did you use Raspberry Pi OS image?

I’ve tried Patchbox 2022-5-17 on my RPI Zero W on a new SD and had no luck.
So I tried my old card again, which was not visible on VNC after some stupid installation. It started again and is visible…but with the Lxde Environment

Patchbox OS is using LXDE, just changed desktop background and home icon. :slight_smile: If you follow this PBOS image generation script, you should be able to get it to a similar appearance:

1 Like