SSH startx command not working

Hello!

I’m trying to connect to my Raspberry Pi 3B+ with PiSound and Patchbox OS installed through SSH in my terminal. I’m able to connect, but when I try to run the startx command to get to the desktop environment, I get the following error:

XOrg X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.15.0-99-generic armv8l Raspbian
Current Operating System: Linux patchbox 5.4.72-v7+ #1356 SMP Thu Oct 22 13:56:54 BST 2020 armv7l
Kernel command line: coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 snd_bcm2835.enable_headphones=1 bcm2708_fb.fbwidth=1280 bcm2708_fb.fbheight=720 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 console=ttyS0,115200 console=tty1 root=PARTUUID=6e0baf53-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
Build Date: 27 August 2020 08:51:48AM
xorg-server 2:1.20.4-1+rpt2+deb10u1 (Debian -- Support)
Current version of pixman: 0.36.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Sat May 8 22:53:36 2021
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
modprobe: FATAL: Module g2d_23 not found in directory /lib/modules/5.4.72-v7+

Using an HDMI works, but I perfer to use SSH connection for convenience if I can get it working. Thanks for the help!

Even though it says FATAL, it seems to only be some warning and it doesn’t seem to impact the X server at all.

After you run startx, use VNC Viewer or a compatible client to connect to the device.