Sostenuto implementation & Question regarding virtual loopback

Is it possible, on pedal down, to enable sostenuto, and change channels? This would enable one to play a different sound when the initial sound is being held.

Q2: does the new virtual Loop back feature create a means to get rid of our physical midi cable loop back set up?

Thanks guys! Congratulations on the update!

1 Like

Yes on both. Though the virtual loopback has to go through a virtual port instead of a hardware port. It won’t spare you any pipelines but it will save you physical ports.

You can map your MIDI pedal to “sustain on” and use it it like an actual pedal.

Using a transform pipe you can map the pedal to “channel argument”. In order to get the right channels, you’ll have to use a virtual loop to rescale or transform your pedal to right value for your desired channel.

1 Like

thank you so much for your quick response. I will try this shortly.
It does bring to mind another question.

can the virtual loop back be used to invert information such that, a single panel press create something to go on, and something to go off?

which makes me wonder if it can’t be used more than once in a patch -so that, you can do the same thing for different situations.

these relate to real world, musical situations, not hypothetical musings :slight_smile:

thanks!
Peter

1 Like

You can create toggles. 2 button toggles are easy. 1 button toggles are a bit tricky.

A 2 button toggles just requires you to scale buttons to values 0-63 for off and 64-100 for on. You have to rescale or transform the values inside a virtual loop pipeline then assign the virtual loop port to the argument mappings you want to toggle.

1 Like

@pje I just described a sketch of this.

2 Likes

Should be 64 - 127 for on. :slight_smile:

1 Like

This first line of this posted by @JoeyButters

…can be used for any number of Transforms in the same pipeline:

Each new Transform would be assigned to a different note…

…then, as I said in post 5 above:

So, if you include the “pre-Transforms” filter (for future-proofing), your entire bank of toggles can be done with
(5 + # of toggles) number of pipes

And don’t forget,

  • some can be ‘On → Off’ instead of ‘Off → On’
  • you might re-use same toggle (turning off a bunch of inputs is common)

whew-I don’t know how you got a virtual loopback icon. I don’t have one w/ my update.

But just to back up for a moment; how do I get sustain to work. I have a peddle set to cc 64. I just want to use the sustain function to react to the pedal press. I am having no luck. Also, I don’t see sostenuto anywhere. How would that be instantiated?
Where would I place this in my current midi cable loopback set up which I will show below…Apologies if there are instructions somewhere.
image

Thanks!
Peter

Hey Peter would you

  1. confirm You see Sostenuto Mode in your version:


    if not,you may only have the new Editor but have not clicked to upgrade the firmware too
    (the option appears when you click Connect…)

  2. upload your preset .mhp file with details in description/here about…

  3. …which pipe property the CC64 pedal is meant to control (I’m not seeing Sustain in your preset)

  4. … and a shot of the Monitor as you press down on the pedal. I’m assuming the pedal CC messages are somehow coming in MIDI A so select that. (we want to see that messages are coming in and what they are)


If you want support on this part, Peter, it will also help to be very precise about this.
eg:

  • Channel when pedal up?
    Channel when pedal down?

  • Messages going via Sustain (& Mode = Sost & Pedal On checked) when pedal down,
    but what should happen when pedal up?

First thing first is to confirm that you can see your midi sustain pedal in the midi monitor. If you can see activity you should easily be able to map it. If you can’t see any activity then try connecting your midi pedal to something else to confirm it’s working.

You are correct- somehow I did not update the MidiHub. When I click connect, I do not see any option to update firmware. Where exactly would it be?
P

right- oh I see cc 64 equals 127 coming up on my third-party Midi monitor. But I do not see it in my MH monitor. Continuous controllers are not filtered. Why would this be? Because of my loop back?
Midihub 2023.11.29 19.47.07 (Preset 1).mhp (1.4 KB)

Are you highlighting the first port pipe so its activity will be displayed in the (MidiHub) midi monitor? The port pipe that your pedal is connected to?

Take everything else out of the equation and focus on whether that first pipe is getting incoming messages from your pedal. My suggestion is to start a fresh new patch. Insert one port, connect your pedal, then check for activity in the midi monitor.

Also FYI, physical loopbacks are no longer needed, so you should always be sending your mappings to a virtual port. This also makes it way easier to share with other users because your patch will always work without the need for a user to reconfigure their own physical ports.

weird-see that I see that MH is getting the information, it just doesn’t show up on the Monitor window. It shows up on my third party monitor window.
And it works normally with it’s established patch.
I did as you said… I started a new patch. no luck

I can’t even update the firmware. I seem to have missed the opportunity when I updated the editor. I cannot get to the information page that has the firmware update button.

I had that same issue with not seeing an option for a firmware update. The editor said it was updated but I didn’t see any of the newly added options. I completely uninstalled the editor and reinstalled the new beta. The option to update the firmware appeared at the first startup.

Try going through the ports to make sure you aren’t connected to the wrong end accidently. If Midihub is blinking but not seeing any midi messages. What model pedal do you have specifically?

1 Like

Maybe you have already updated? What version do you see displayed at the bottom right of the Editor’s window, when Midihub is connected?

i.e, @pje, you will see something like either:

  • old Screen Shot 2023-11-30 at 09.31.34

    or

  • new Screen Shot 2023-11-30 at 09.31.02

(“XKG4” & “XSF” are just the end of the names of my MHs)

1 Like

it says 1.1 4.0
That is why I thought I had updated.
But there is no sostenuto option in my sustain tool. only “chord”

Make sure you’re running Midihub Editor 1.14.0 - Help → About Midihub Editor (or Midihub Editor → About on macOS) should say it’s 1.14.0.

Inserted a sustain pipe, and now it works. The incoming cc 64 also shows up on MIDI Monitor. I don’t know why it did not work last night.
-it is a sustain tool. It’s sustains the note. So why does it need cc 64 to trigger? ItTurns on if I use a CC 63 button press, but no sustain.
-lastly, my screen says I have 1.14 in the lower right corner. But there is no sostenuto tool.
Thanks!
Peter

LpBackw:sus…mhp (1.4 KB)