Shairport with pisound

Hi all,

I have tried to setup a Shairport with pisound, everything worked well but I can’t seem to connect it to the hw:pisound hardware. Does anyone have experiences with this?

My settings are this. Thats it. I can connect Airplay to patchbox, but there is no sound coming out.
Might be a offtopic issue, but wanted to chip in in case someone tried it here.
Also tried hw:ALSA.

general = {
  name = "patchbox";

alsa = {
  output_device = "hw:pisound";


Hi, it could be using an incompatible sampling rate by default. Pisound natively supports 48000, 96000 and 192000 rates. Ideally, the software should be configured to use one of those, or if that’s not possible, some software resampling stage should be set up.

Thanks for the quick answer! Ah damn, too bad. Someone tried with “pulseaudio” backend, but I haven’t managed to do that, and I got an error. In case someone is interested, started to ask there:

It actually worked out with an older shairport:
So I dont understand why it worked there. But I have severe lags in transmitting the audio so thats why I tried it with the new system. Hope it somehow works, and I understand it is a bit offtopic here. Thanks!

It’s not off topic :slight_smile:

The error shown in the log says the card is busy. By default Patchbox OS has Jack backend set up, as it allows software that supports Jack to work at the same time. If possible, try configuring Shairport to use Jack backend. If it’s not possible, try stopping and disabling Jack and try starting Shairport again. To stop and disable Jack, do:

patchbox module deactivate
sudo systemctl disable jack
sudo systemctl stop jack

The first line turns off any Patchbox module you may have had activated, so it won’t end up starting Jack on next reboot.

Hi, thanks a lot, that really made it work. However, there seems to be Stutter problems and they cant seem to be handled, it is the same problem in this topic below:

Hope I can somehow manage to work, It is sort of a mystery, because it worked with an older Shairport installation without any glitches (but with 3-4 Seconds delay).

Did you try what was suggested in the issue?

@microfx, do you have any insights? :slight_smile:

Hi, I’ve set up software resampling on ALSA backend that could help to get Shairport working, see here: Raspotify output on pisound to play along

For the Shairport configuration, use “default” instead of “hw:pisound”, so it ends up using the audio path with automatic resampling.

Hi Giedrus,
Thanks so much, I had not much luck so far, will try what you suggested and will post about the progress :slight_smile:

Hi Giedrius,

Finally I could try it out, and with “default” it works perfectly. Without much lags even!
Thanks so much <3

1 Like