Segmentation error when trying to run Cardinal on patchbox os desktop


I installed DISTRHO Cardinal using kxstudio repos and I get a seqmentation error when trying to start the software. What am I doing wrong here?

Also could we have Cardinal as a module for Patchbox and/or MODEP headless plugin plz? :smiley:

I’m also struggling. First of all I tried the jack standalone version… But there have been several issues.
Seems as if it is glib related, because of libGL errors.
After installing mesa-utils and trying to run glxinfo, I got errors with a GLXBadContext, major opcode 151, minor opcode 6. LIBGL_ALWAYS_INDIRECT=y didn’t help. I am lost now… Hopefully someone with better knowledge can help.
Cardinal would be a absolute + + +, because I could use an multiport IO card with it.

Oh, just tried another approach and I got it running as standalone application, which in my case is perfect.
I installed libgl1-mesa-glx and mesa-utils to get it running.
Could get it running on the local desktop but not on a remote desktop - which after a little thinking makes sense to me.
Now I am trying to use my multiple ports card.
Hope this helps.

My problem was that I was running a VNC virtual desktop and Cardinal didn’t like that. I did get this working by using VNC a bit differently.

What was the solution for VNC?

Now I am interested. You managed it on the VNC viewer to get it to run?

First I created a vncserver command line instance with a virtual desktop with address like Got the segmentation error. But when I activated vnc server from raspi-config and connected with without the virtual desktop thing cardinal started up. It does run, but not in a usable way with the gui open over vnc. falkTX said that he’s working on a remote gui for cardinal, so maybe some kind of headless solution might be in the future.

1 Like