RPI once pisound is temporally removed


#1

Some times i move the sd card in the Raspberry Pi hardware that has the pisound plugged and install to a separate Raspberry Pi without the hardware attached.

When I used the command alsamixer it says it cannot open mixer when the files are still there. Thats typically where i also adjust what sound card im using.

How can I use alsa again and also how can I playback sound of the same OS that I have pisound installed but without the pisound hardware attached?

Many thanks


#2

Which files, do you mean the ~/.asoundrc?

If yes, just temporarily rename it after switching:

For use without Pisound:
mv ~/.asoundrc ~/.asoundrc.bak

For use with Pisound:
mv ~/.asoundrc.bak ~/.asoundrc


#3

sorry I mean’t the alsa files are there but when I go to uses the command alsamixer its not recognised


#4

Sorry, it’s still unclear to me which files do you have in mind. :slight_smile: Also, are you running Raspbian Lite?


#5

Im running raspbian lite.

So prior to installing pi sound. I would use, i think it was, the alsa sound card being used.
If I were to remove the pisound hardware after installing the pisound libraries, the RPI for some reason cant use devices such as alsamixer. It works however again when I attach the pisound back


#6

Hey, I tried attaching and detaching Pisound, alsamixer seems to work fine.

Could you show some of the commands you run and whether they print any errors?


#7

there arn’t any errors just after typing:
$ alsamixer

it says:

$-bash alsamixer: command not found

Maybe something of pisound gets prioritised once its installed that doesnt change when the hardware is removed?


#8

This seems to be an issue with your OS image - it can’t locate the alsamixer executable. Running alsamixer on my system based on Raspbian Lite runs the command just fine…


#9

well odd thing is that alsamixer will run fine when the pisound is attached, just not without


#10

This shouldn’t be related to Pisound being on or off, the message given is a generic one that means the executable couldn’t be located.

What is the output of:

which alsamixer

when the Pisound is attached and when it is detached?

On my system it is:

pi@raspberrypi:~ $ which alsamixer
/usr/bin/alsamixer

When Pisound is detached, try executing it using full path, like:

/usr/bin/alsamixer

#11

its odd. When the Pisound is detached and i use the command:

which alsamixer

its does say /usr/bin/alsamixer

but when i use the full path :

/usr/bin/alsamixer

its says:

cannot open mixer: No such file or directory

edit: Im also noticing when i run alsamixer with Pisound attached its there but I can’t adjust volume with it. It actually just shows a bar saying 00 with the meter going up from green through white into red. Which is causing clipping, except I can turn the audio down in the program Im using to playback audio( which is ecasound). Despite this the bar remains the same


#12

Pisound has no software controls in ALSA mixer, the volume control is analog on the hardware itself.