RPi 4 Bluetooth Connection Fail [solved, possibly]

I get a ‘Connection Error’ when trying to connect from the Scan page of the Mobile App to the Raspberry Pi 4. When I try it manually, I get the ‘Protocol not available’ message.

bluetooth fail 2

Here’s the bluetooth status, showing all running. Using bluetoothctl I can see the device trying to connect, made sure it’s trusted.

Any ideas?

bluetooth status

What is the output of:

sudo systemctl status pisound-ctl

?

You may inspect its log by running:

sudo journalctl -u pisound-ctl

I’ve tried this with a couple of phones, sames result. I should mention that I’m running remote-desktop server. I tried with ssh, same result.

Also I don’t have my pisound card yet, it’s delayed due to ‘Brexit’ :scream: But I was guessing that wasn’t necessary at this point?

The last lines of the log…

Can the app connect over WiFi instead? That would do for me.

The server runs only if Pisound is attached, so you’ll have to wait for it to get delivered. :slight_smile:

Ah ha :slightly_smiling_face:

Yes, with the pisound attached, the mobile app does connect. I still see that protocol error pop up btw. I find the app keeps disconnecting, but could well be my phone. I’m not planning to use it for control that much anyway. The plan is more midi-controller knob-twiddling.

We’ve seen these unexpected disconnects happen when some bluetooth related system libraries out of date.

Another reason could be, if you’re using the realtime kernel, that the libraries are actually too new for the kernel. Unfortunately there’s been no good updates to the RT branches yet on the RPi Foundation’s kernel tree.

OK, as I say not a major thing for me. I’ll try with a different phone anyway.

Not for now, but if one day the mobile app could be made to connect via wifi that would be a good thing IMO. I’ve no idea if that’s an easy or difficult thing for you, of course. I often find BT behaves oddly at times, I think that’s the common experience.

Update, after reading around, people were reporting bluetooth dropouts on standard Raspbian, with BT keyboards for instance. A suggested fix was to copy the firmware from the latest OS update (the one at the end of 2020).

Files in /lib/firmware/brcm

I did that on my patchbox OS (keeping a copy of course) and indeed after a reboot, my phone has a stable connection from the patchbox app to the pisound.

Not saying this is a definitive fix, it’s a hack, but working at the moment.

1 Like

A quick go with the app - it’s very cool :smile:

Controlling the parameters from a phone, yes it’s handy but fiddly in a live situation. But I didn’t know about the MIDI learn feature - now that is really good!!!

1 Like