Routing MODEP outputs to a DAW

It looks fine, Patchage should be able to connect to the running Jack server. Could you start Patchage from within a GUI terminal on your desktop?

Just run patchage and see if it provides any additional info in the terminal.

Strange, when I click on “Connect to Jack”, it kind of freeze for a moment and than nothing. I don’t get the message I had previously…

Not sure what could be wrong. Just a wild guess, but maybe Jack is having overruns and is not stable - try again with reconfigured Jack server with increased buffer sizes, like -p 512 -n 3, just to make sure this issue is not caused by too small buffer sizes.

I’m not getting any overruns in MODEP unless I do something heavy (like a backup).
Changed Jack settings to -p 512 -n 3:

● jack.service - JACK Server
   Loaded: loaded (/lib/systemd/system/jack.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2021-09-20 09:08:34 CEST; 1min 20s ago
 Main PID: 393 (jackd)
    Tasks: 9 (limit: 985)
   CGroup: /system.slice/jack.service
           └─393 /usr/bin/jackd -t 2000 -R -P 95 -d alsa -d hw:audioinjectorpi -r 48000 -p 512 -n 3 -X seq -s -S

sept. 20 09:08:35 patchbox jackdrc[393]: No jack_get_descriptor entry-point for mod-midi-broadcaster
sept. 20 09:08:35 patchbox jackdrc[393]: No jack_get_descriptor entry-point for mod-midi-merger
sept. 20 09:08:37 patchbox jackdrc[393]: Cannot connect ports owned by inactive clients: "mod-host" is not active
sept. 20 09:08:39 patchbox jackdrc[393]: port created: RtMidiOut-Client:midi/playback_1
sept. 20 09:08:40 patchbox jackdrc[393]: port deleted: RtMidiOut-Client:midi/playback_1
sept. 20 09:08:43 patchbox jackdrc[393]: port created: RtMidiOut-Client:midi/playback_1
sept. 20 09:08:44 patchbox jackdrc[393]: port deleted: RtMidiOut-Client:midi/playback_1
sept. 20 09:08:47 patchbox jackdrc[393]: port created: RtMidiOut-Client:midi/playback_1
sept. 20 09:08:53 patchbox jackdrc[393]: port created: RtMidiIn-Client:midi/capture_1
sept. 20 09:08:53 patchbox jackdrc[393]: port created: RtMidiOut-Client:midi/playback_1

but I still don’t have audio in Patchage…

I really don’t get how MODEP uses jack without any problems and other can’t even see it running…

Something must be misconfigured or some incompatible version of some software/library is installed on your system.

OK, I’ll make a fresh install tonight to test this with a new system and report back.

Hey buddy, did you manage to get this working?
I’m currently putting together a little rig with a Pi for Modep and a Pi for Reaper, but it’s messy.

If you can get this working and routed the way you like on a PI3A ill he trying to copy on a Pi4.
Using a Pi4 with a 7" touchscreen is the plan, with a Behringer C1 as my mic/line input. The screen will show the reaper channel I’m recording to and allow for quick checking of the model UI page too.

Ah man, I’m far to excited for this ha ha

Sorry I took so long to report back.
So, I’ve found out that the fact that I was connecting to the Rpi thrue RDP doesn’t allow to access JACK with GUI, when connecting with hdmi or VNC, I can now see everything in patchage.
I’ve created a topic on treefallsound’s forum about that the bottom line beeing, you can route any output from jack to a Reaper input.
Means, you can route MODEP outputs to Reaper’s inputs 3&4 (1&2 being already assigned to physical input) and you can also route individual effect’s output to other Reaper’s inputs.
For that you can usage patchage but I find it a bit messy, so I just use jack_connect.
In order to determine what output to connect to what input I use jack_lsp -c

I’m in the process of making a bash script to automatically connect MODEP’s outputs to Reaper inputs 3&4. If that works OK, Ill probably try to also map the other effects because it actually might be interesting to be able to record you guitar sound a various stages of processing.
However jack_lsp doesn’t give much to work with so it’s not as easy as I hoped…

1 Like

This is amazing, thank you for the detailed feedback!
I’d be really interested in how you go about scripting the jack connections as I’ve not done too much with jack in the past.
Is your rdp issue avoidable using a VNC client as an alternative?

Yes, works with VNC.

1 Like

OK, I’ve made a little script to automatically connect MODEP’s outputs to Reaper’s input in Jack.
It’s in it’s early stage (meaning it’s a bit messy) but you can get in on github:
It’s designed to connect the outputs to Reaper’s inputs 3&4 but using “jack_lsp” command you can change the scripts settings to accomodate your needs and connect to DAW you’re using.

I’ll be pretty busy in the next couple of weeks so I won’t work much on the script, however, any feedback would be appreciated. And I’ll manage to correct bugs if any.

1 Like

This is flipping brilliant, thanks for sharing it!

Wait until you’ve tested it… :wink:

Ha ha, hopefully tomorrow!

Took delivery of a SmartiPi touch Pro case today, so was able to put my Pi4 with a screen finally.
Was able to take the Pi 3 that I had with my screen and pair that with the Pisound I have, so slightly downgraded but will still serve as a pedal for my guitar playing.

Now I can get Reaper installed on Patchbox and have a good look at getting the connections routed.
Genuinely excited!

1 Like

Reaper installed, but no jack instance running next. Will look into that Wednesday, then look at adding your script into the mix.

***UPDATE ***

Took a while to get a chance to get my JACK instance sorted, but now it is.
Just needed to adjust to 48k for my USB audio device.
I’ve also git cloned your script and tried running it, and it didn’t generate any errors sothats a good start.

Next time I get a chance I will be seeing it the script does indeed give me channels 3 and 4 in Reaper when I change the settings for it.


Progress! In a way, ha ha.
The alesis interface was atrocious, making a lot of digital noise when putting a guitar through it, so it has been subbed out for a Zoom U-24. Much better for me as it does phantom power so I can do vocals on a condenser mic through it too.
Adjusted the script to map the outs to 5 and 6 of the jack inputs for reaper, and it seems to work nicely. I love it.
I still have a problem with some minor noises like a ‘digital fizz’ that seems to happen every few seconds almost like clockwork, and it seems to be coming from MODEP. If I disconnect the audio in from the out it doesn’t happen, but when it’s routed to the output it happens, regardless of path the audio follows.
If I can iron out that then I’ve got a system I’d be happy to take out as my portable recording rig.
In fact if it works I wouldn’t mind building a second system to act as a multitrack recorder for my Berhringer X18.

1 Like

It might not be the same thing I encountered before, but if you have audio cables going close to the Raspberry Pi near the power connector side, the WiFi signal actually ended up injected into my audio stream. Disabling the WiFi interface fixed the issue. If that turns out to be the case, and you’d prefer keeping the WiFi on, some shielded cables should help avoid the noise.

The command for disabling it I think was sudo ifconfig wlan0 down

1 Like

That’s a really good point, thanks mate!
I am using WiFi at the moment for controlling the modep effects while Reaper is on the Pi’s touchscreen, but I’ll try disabling it and see if that is the cause.
I’ll try changing cables too.

1 Like

So I’m still getting all kinds of funky noise out of this bad boy. I’ve been messing around with the jack settings and Jack seems to be fine, it just keeps generating loads of digital noise and distortion.
Tomorrow I’m going to try putting the Pi with my Behringer X18 desk and seeing if I can have that work with it; while I’m waiting on a new shielded XLR cable to arrive (my current one is old and could be damaged) I have a theory that the Zoom U24 could be putting a strain on the power and causing issues.
It shouldn’t, drawing power from the USB3 port of the Pi, but its worth testing an interface with its own power supply.
Excited to have 16 inputs to play with ha ha!

1 Like

FFS, trued all my shiny new shielded cables and still dodgy.
Changed my JACK settings via patchbox from 2 to 3 for the last value and it fecking worked flawlessly ha ha ha.
I can focus on script to open reaper before routing the inputs and then work on my MODI pedal.

Ordered an expression pedal too, so incan try capturing it via my arduino analog pins.

1 Like