Pure data module creation not working

Hi all,

I have been trying to make a basic pure data patch module. I followed the first few steps (within step#1 actually)

Ended up being able to successfully type in these lines

“cd /usr/local/puredata-patches
sudo mkdir -p basic
cd basic
echo “#N canvas 2 95 450 300 10;” | sudo tee basic.pd
sudo wget https://community.blokas.io/uploads/default/original/1X/8ea6c9dba43a1dcbf74232635bba1260d0524a62.jpeg -O basic.jpeg
sudo nano /usr/local/puredata-patches/basic/blokas.yml”

But even though the final line worked, I still cant find a new module in my pisound app under the header ‘pure data’ (usually there’s 15 built in examples but I’m expecting there to be another one named basic? so 16 in total? but its not showing up). Below is the picture of the code seemingly working. Not sure maybe there’s another step to it? Would love some help!

Make sure the contents of /usr/local/puredata-patches/basic/blokas.yml match exactly what’s in the tutorial you’re following. The whitespaces are required, and make sure that the file is properly saved.

Also, /usr/local/puredata-patches/basic/basic.pd must exist for the patch to be listed in the app.

Okay so I noticed my pd and jpeg file was outside the pure data ‘basic’ folder. I tried to drag it in but it doesn’t seem to allow me to do so! Some sort of aurhtorization problem it seems.


sudo chmod -R 777 /usr/local/puredata-patches

It will grant full access to everyone in this directory and its subdirectories.

Hey Giedrius,

I tried that line and it did alow me to gain access and drag the folders. Yet, it the patch does not show up on my phone.

Strangest part of it is, I can clearly see the number of patches has bumped up from 14-15 yet it won’t show me my patch. Even weirder is I can only count 13 on the app itself.

Any help would be great. Thank you for replying so far.

Did you fix up the blokas.yml file to be exactly like in the tutorial, including all the whitespaces?

You may run this command to see some more information about the Pisound app:

sudo journalctl -u pisound-ctl -f

It will show the latest logs in real time, try connecting with the Pisound App and getting the list of patches, it should print any errors that might be there with the Basic patch.

1 Like

Okay. I’ve realised that the problem is probably whitespaces (Just learned about the actual concept). I downloaded the ready made ‘basic’ patch and it showed up. Probably will go back and try to do it all again just so I can get a hang of how to make PD patches properly. Thanks for the help :slight_smile: