Pure Data MIDI ports issue

Hi, I did this update, and now Pure Data doesn’t detect any MIDI ports. Any idea how i can get them back?

Hi, I have moved your post to separate topic from Problem with MIDI Interface

Can you describe in more detail what are you seeing? What is the output of amidi -l?

Pure Data usually creates its own virtual MIDI ports which you have to connect to other virtual or hardware ports using aconnect or aconnecgui.

I decided to update the firmware as you described because my Pi was freezing when I put alot of MIDI data through it.
I’m using a Raspberry Pi 3 Model B. I installed Raspbian, updated Raspbian , then installed Pisound, then installed Pd from pisound-config.
Pd worked OK (but freezing sometimes), but when I updated the Pi firmware using sudo rpi-update the midi devices disappeared from Pd.
When I open Pd, and go to Media>MIDI Settings there are no input devices or output devices to choose from, only “none” is listed.
Previous to updating the raspberry pi firmware I had one input device listed, and one output device listed. I can’t remember their names but they worked OK.

amidi -l gives

Dir Device Name
IO hw:1,0 pisound MIDI PS-3RXHBZW

Make sure to use ‘ALSA MIDI’ in ‘Media’ menu of Pure Data, then use aconnectgui (sudo apt-get install aconnectgui if it says command not found) to make the virtual connections between Pisound’s and Pure Data’s MIDI ports.

OK thanks, that works well so far, hasn’t frozen yet!