Pure Data able to start via the Button only when connected by SSH

weird situation here… when i’m connected to my Pi over SSH I cna press the button and it launches the file ‘main’ from puredata-patches.
if i’m not connected via SSH nothing happens… if i then log in and run top i can see that pd is not running? but then pressing the button starts everything as expected.
any thoughts?


We resolved this issue via the chat on the website - right now we worked around by specifying the ‘-nogui’ instead of $NO_GUI on this line:

We’ll investigate this on our side, but so far I was unable to reproduce the issue on my own system.

Let us know if anyone else hits the same issue!

I suspect you need to export NO_GUI

I suspect the cause of the issue was the automatic detection of a display to use (like using HDMI one if connected, otherwise try to locate any remote desktop displays, otherwise fall back to -nogui), if anyone knows better methods, let us know. :slight_smile:

For info (not sure if it’s useful or not, depends if any changes were made to pisound download package )
I installed my first pisound on 20th March and managed to get button working with device running standalone off a battery. That time I installed puredata from terminal window. Then managed to snap the sdcard (long story!) so reinstalled OS from same raspberry stretch disc image as before, re-downloaded pisound this Monday (16th April), and this time downloaded puredata using the option in pisound-configuration. At that point the button would only launch pd when I was logged in over SSH (via X quartz on mac osx)… Until giedrius jumped on the case and helped fix it of course!!!