Problem adding additional USB Interfaces with jack_load

I’m trying to add an additional USB Interface to modep like so:

jack_load USBDevice audioadapter -w -a -i "-d hw:1 -p 128 -n 3" &
sudo systemctl start modep-mod-host modep-mod-ui

In modep webui I can then see the additional ports, however I cannot connect them. I get the following javascript error:
Uncaught TypeError: Cannot read property ‘attr’ of null
at init.highlightInputs (pedalboard.js?v=1612600901:1698)
at init.JqueryClass.$.fn. [as pedalboard] (modgui.js?v=1612600901:1233)
at init.startConnection (pedalboard.js?v=1612600901:2136)
at init.JqueryClass.$.fn. [as pedalboard] (modgui.js?v=1612600901:1233)
at HTMLDivElement. (pedalboard.js?v=1612600901:1863)
at HTMLDivElement.dispatch (jquery-1.9.1.min.js?v=1612600901:2)
at HTMLDivElement.v.handle (jquery-1.9.1.min.js?v=1612600901:2)
at HTMLDivElement._super.bugsnag (buy-button-storefront.js?v=1612600901:7433)

They can be wired up using Patchage (or using jack_connect on the terminal) however.

The patchbox installation is only a few days old:
Linux patchbox 5.10.11-v7+ #1399 SMP Thu Jan 28 12:06:05 GMT 2021 armv7l
Modep was installed using patchbox-config only 2 hours ago.

Does anyone have any ideas how to get this working?

Have a nice day.

Hmm, just a wild guess, but maybe there’s some string reported by this device that’s not handled well in MOD code.

Did you try alternative ways of loading the card into the system, like alsa_in and alsa_out clients as suggested on

I’d like to know this too.
Some help would be nice.

This is what I’ve tried:4

Yeah, I tried alsa_in as well. Those won’t show up in mod-ui unfortunately, while jack_lsp happily lists them.
I think my issue is with the naming, as the input ports are called capture_1 or 2, just like the default inputs. I tried aliasing them but to no avail.

I’m able to connect them using jack_connect on the cli however. Using a python script to connect to the mod-host socket also works. But this will further confuse mod-ui.

Edit: Also tried an .asoundrc with a multi device configuration, however I get pretty bad audio glitches (caused by drift?)