Powering External Gear through MODEP?

#1

Getting strange issues trying to play my EWI-USB on my Pi3B with pisound running MODEP. Things are fine on regular Raspbian Stretch (on my Pi3B+ with a pisound HAT), but the MODEP Pi with pisound only powers it up under certain circumstances, which aren’t consistent.
(There’s a little LED on the EWI to say when it’s on.)
Using a 2.5A power adapter in both cases.

At first, plugging the EWI on the Pi before or after booting didn’t produce any result. The LED wouldn’t light up. Tried with a powered USB hub (which would light up the LED without the Pi) and the LED would go off while the Pi was booting up.
Eventually plugged the EWI at a certain time during boot and the LED did light up. Now, for the first time with the EWI, the USB-MIDI in was showing up in MODEP. Plugged that to JX-10 and it worked as it does with my WX-11. Saved the pedalboard, rebooted… The EWI does light up but the connection to USB-MIDI is lost. Had to make it again in the MODEP UI.
Tried the same trick of plugging the EWI during boot up and it doesn’t light up at all, anymore. Can’t consistently reproduce the scenario in which it’s working and, even when it’s working, it requires access to the UI.
My Alesis Vmini also uses USB-MIDI and it’s worked consistently since day one. As long as it’s plugged in before boot, MODEP recognizes it and its connection to setBfreak is maintained across boots. Same thing with my WX-11 (which uses a separate power pack and connects through MIDI). These things just work, consistently. Played with them for hours on end and, apart from stuck notes on the Vmini (not a single stuck note on the WX-11), it always worked.

Also been trying to make the Raspbian Stretch Pi to work with my Eigenharp Pico. Only works once in a while, with no indication as to what makes a difference. It’s not about plugging things in a certain sequence, leaving them plugged in during reboot, or using a powered USB hub. The same method works consistently on a BeagleBone Black (with Bela cape).

Sounds like there’s something wonky about the Pi’s USB controller, as @thetechnobear has it. Wonder if there’s any way to make things work more consistently. That’d be helpful.

0 Likes

#2

MODEP is built on top of Raspbian Lite, there have been system package and kernel updates released since the MODEP image was generated. Try getting the system upgraded:

sudo rpi-update # Kernel upgrade

sudo apt-get update
sudo apt-get upgrade # Package upgrades

It’d be best if first you’d upgrade your kernel, and see if the issue still persists, then upgrade the packages, this way we’d know whether the issue was in the kernel.

0 Likes

#3

Curiouser and curiouser…
After kernel update, the LED sometimes lights up and the MIDI port sometimes shows up, but it depends on the USB port, the time when it’s plugged in, … the outside weather?
Even when the connection is made, the EWI-USB doesn’t sound like it’s sending notes, strangely enough. Weirder than that, it does send CC so that MIDI Learn on a parameter works but note-on doesn’t have the expected effect.
(This is with the January 22 version of MODEP on a Pi3B board with pisound.)

Maybe it’s a problem with the controller or the cable or some such, but the same controller and cable (and pisound HAT) can work with the non-MODEP Raspbian Stretch.
Will try the package updates and upgrades tomorrow, but this is all a strange situation.
Did have other issues with USB on the Pi3B and Pi3B+ boards running non-MODEP Raspbian Stretch, trying to run MEC-app from @thetechnobear. That same app works fine on BeagleBone Black with Bela. So maybe there really is something wonky with the USB stack on Pi hardware. But it’s also funny that my Alesis Vmini (same kind of USB connection on the same Pi setup) runs fairly reliably (apart from a few stuck notes on MODEP).

Again, will investigate further soon. Just wanted to give an update, after the kernel update.

Ok, getting some notes. Changed the cable (used the one from the Vmini) and it helps a bit. But many notes are actually missing. Latency is decent but a run of notes may be skipped.

Wonder what code to run to monitor the MIDI input. Shouldn’t be hard to find and could be useful. Especially if it writes to files.

The thlot pickens.

0 Likes

#4

You could use ‘aseqdump -p ##’ where you should replace ## with the client number of your keyboard. Find the client number with ‘aconnect -io’

This will give realtime display of midi i/o for a specified device (or all devices). Should also be able to dump this to a text file…

2 Likes