Polyphonic Octatrack via Dispatcher

I want to use my Octatrack as a polyphinic multisample Fender Rhodes and I’m not clear about how to go about it.

I have a multisample sliced fender rhodes copied to all 8 tracks. I want the dispatcher to round robin between tracks so that I can play polyphonically.

I figured I could just use a pipe made up of a very simple MIDI KEYBOARD to DISPATCHER to OCTATRACK MIDI but he dispatcher notes say that it should be used in combination with virtual pipes and channel remap - but i don’t understand why.

I found a polyphonic syntakt patch on patchstorage, and i don’t understand it at all!

any guidance would be appreciated

Have you tried this yourself?

If it doesn’t work, please upload your patch…
(maybe starting as simple as this Screen Shot 2024-05-08 at 16.01.00)

…and MIDI Monitor shots (showing 8 notes playing) to help see why.

the Dispatcher help should be read in full:

…combined with Virtual Pipes and Channel Remap to route the MIDI data to the necessary MIDI outputs.

ie. it’s a hint to users Dispatching with more than one output

1 Like

ah ok perfect - that’s exactly what my patch looks like, but I had some configuration wrong with the octatrack - works perfectly thank you!

now i just need to add a pipe to translate velocity to track volume because insanely octatrack doesn’t respond to velocity!

the patch I think you referenced (but didn’t link to so I’m not sure) has a velocity-set CC Transform

just look at the Dispatcher line and copy that in

yes, but i want to understand why it works! though i think i do, i posted prematurely and then deleted it - i need to play with it and make sure…

but setting it to “before” instead of “replace” means that it changes the velocity value without deleting the note on message? that’s my main confusion

ok, i got it to work, but i had to set it to “after” instead of “before” … not sure what i’m doing, but it works…

Loath to comment in detail, cos I might be thinking about a different patch (pls post link!) but to get a better understanding follow the Monitor while the Transform is selected.

Whether Before or After works better is a Octatrack issue not Midihub.
(In my Volca Drum Velocity mapper, all the Transforms are Insert Before cos the Korg device wanted any settings changed before the note sounded)

here’s the link - polyphonic syntakt

not sure what’s going on in this patch!

the velocity works now with the octatrack, but sounds terrible, gives awful pops and the volume differences are very unnatural - but that’s an octatrack issue and maybe my keyboard as well

OK, that’s useful

I’m not sure what’s preventing you from following the flow here, whether it’s the use of virtual i/o pipes or that you’re not using Monitor to see the modifications as messages go thro the pipes…

but essentially there are only two aspects to pete-midi’s work:

  1. the Dispatcher sending distributing notes to Ch1-8
    then preceding each note with a CC2 (val=vel) and then Limiting the velocity itself to 90
    (assume CC2 is an OT thing)

  2. The rest of the patch is using virtual i/o pipes to duplicate any incoming CC&PB out to all eight channels.
    pete-midi has sensibly used more than one virtual in order to avoid duplicating the Filter 8 times

    Now users set pipeline order to suit themselves, so you might like to drag them around to help visualise the flow:
    This order works for me: Screen Shot 2024-05-09 at 13.25.59

    It might help to print out the pipe panel or draw arrows on a PC screenshot to make the
    {MIDI A|B} → C → D → B → MIDI A flow obvious.
    Then try sending a CC into A|B and follow its passage using MIDI Monitor.

Just guessing but pops might be cos you are sending CC after sample playback starts.
An OT forum might help

I don’t know why pete-midi wanted to Limit velocity to 90, but you might want to try experimenting with a Rescale instead to squeeze 1 → 127 down to say 32 → 95 and go from there

Unlikely a keyboard issue unless you’re allowing through messages OT doesn’t like (again MIDI Monitor will give you the answer)

OK I’m off back to troubleshoot this issue be grateful if you’d give it a try and tick a box (I recall you using a PC)

1 Like