[Plugins] ALO looper plugin build

I currently have Sooper Looper on a pedalboard but I’m not a huge fan as it doesn’t really give me what I’d like. After a Google around I came across the ALO plugin (GitHub - devcurmudgeon/alo: A Looper plugin for MOD duo) which is now part of the GitHub - moddevices/mod-plugin-builder: MOD Plugin Builder and I’d really like to give it a try as an alternative looper but I don’t know how to go about building it for the PI and getting it integrated into MODEP.

I’ve tried to look at the mod-plugin-builder docker (details from [GUIDE] Many More Extra MODEP Plugins) but didn’t get very far as I struggled to get git working to update the submodules - kept on failing on network connections even though I’m using ethernet (not wifi).

Is there a simple way to get the plugin build for MODEP - it uses a .mk build file.




Here’s how to build it, and fix one crash that happens when placing it in the pedalboard:

Install prerequisite library, get the source:

sudo apt install liblilv-dev
git clone https://github.com/devcurmudgeon/alo
cd alo/source

Then edit the alo.c:

nano alo.c

Change this line:

if (self->loop_index % (self->loop_samples / self->loop_beats) == 0) {

so it looks like this:

if (self->loop_beats != 0 && self->loop_index % (self->loop_samples / self->loop_beats) == 0) {

This avoids a division by zero crash, as loop_beats is still 0 at the beginning.

Hit Ctrl+X, then Y to exit and confirm saving changes.

Then build and install:

sudo cp -r alo.lv2 /usr/modep/lv2/

Restart MODEP so it sees the new plugin:

sudo systemctl stop jack
sudo systemctl start modep-mod-ui

@Giedrius Finally had chance to try your solution and it’s built and installed and appears in the MODEP UI. Thanks.

Unfortunately, when the plugin is not in ‘bypass’ mode, no audio comes through or triggers starting the loop. Is there a way to debug/view logs to try and see why there is no output when the pedal is enabled.

Thanks for your help with this.

Set LOG_ENABLED = true here: https://github.com/devcurmudgeon/alo/blob/master/source/alo.c#L86

Edit log file path here: https://github.com/devcurmudgeon/alo/blob/master/source/alo.c#L95, set it to /tmp/alo.log, as MODEP runs as modep user, and does not have access to /root.

Build it again and reinstall, you’ll find the log in /tmp after using it in MODEP. :slight_smile:


@Giedrius Thanks. Was able to do a bit of debugging but in the end it my main problem was that the clock wasn’t triggering the pedal so never started. Once I’d figured that out, loop recording started. It still doesn’t play sounds through the pedal - only on playback of the loop so I just feed my instruments to both the ALO looper and the output.

Still need to play around a bit with it but seems to be working now. Thanks for your help.

1 Like

I opened an upstream issue for Alo here https://github.com/devcurmudgeon/alo/issues/6 and encourage anyone interested to contribute to it.

1 Like

@ElijahLynn if I understand correctly, Giedrius and Greg209 got it working, so it should be possible for you too :slight_smile:

Can you confirm that you’ve got a global midi BPM clock running? Also as Giedrius mentions, note that Alo only outputs the loops, so you need to route your original to the output separately.

1 Like

A dry/wet param could help make it more straightforward. :slight_smile:

1 Like

Yes, it would :slight_smile:

Thanks for the reply! I don’t see a global bpm plugin in Modep library. I’ll look for one and see if I can install it. I searched for “global” no results. It sounds like it might not be a plugin but a feature of Mod Duo. I am running an older MODEP, about 6-12 months old, so maybe it is in a newer MODEP image.

I setup the input to go to the output and Alo, then added a generator and linked that midi to Alo. Can you look at my screenshot and see if that looks right? (the Tinygains are just so I can monitor the levels)

I just updated to latest MODEP in this thread MIDI clock seems not working. I seem to think that there is a way to set a global bpm here but am not seeing anything that would do that. I am a bit lost here, admittedly.

I just used (started) the internal clock for in Patchbox at the bottom of the window - nothing connected to the trigger. No plugin either.

1 Like

K, I don’t see anything there, I will try updating Patchbox for that. I did just update modep but no go there, maybe it is a higher level up thing.

Can you click on “MIDI PORTS” - I don’t have that. It might pop-up the window to allow you to select the Internal clock… maybe.

Update: sorry - I do have that option and it’s nothing to do with the clock.

Not sure why you don’t see the BPM clock thing, sorry.

I’ll flash the latest and greatest. I ran patchbox update just now but no go.

Alrighty, fresh flash and patchbox wizard install of Modep has the global BPM option!

Testing now.

UPDATE: It is ALIVE!! (can’t reply more than 3 times in a row without someone else replying)

Thanks all!


Here’s a reply so you can reply again to the reply :smiley:

I am trying to use the ALO looper, but the global BPM option is turned on by default and I can’t run it in free-running mode. Is it somehow possible to disable the global BPM option in Modep?