Pisound + Kodi?


I’m trying to use pisound with a media player in raspbian. I’ve found Kodi as the best working player for raspberry, but I don’t know how to configure it to use pisound as the default sound board. Pisound is working great with raspbian and sonic pi, but when I run kodi it doesn’t recognize pisound.

Any ideas on how to configure this?

KODI is completely configurable from system audio inside the Application, i have it working on a raspberry and an ubuntu box

1 Like

Yes, I saw that. I suppose that I have to change the “Audio output device” setting to “pisound” or something like that, but the options given don’t show this possibility (I have no access to my raspberry right now. I’ll try to post all the options later).
Am I wrong, or there is other thing that have to be done?


Hi, it should be mostly enough to use Pisound as output. Also, Pisound supports 48kHz, 96kHz and 192kHz sample rates, so it’s best to match it in the settings.

Also, if there’s already some audio software running and using Pisound, it will be unavailable for other audio software, it even not be appearing in the selection list, so you may have to close the audio programs you don’t use at the moment.

1 Like

No luck with this.
I tried selecting the “default” interface in qjackctl to make sure that there is no other software using Pisound, but when I run Kodi, the only options for “Audio output device” still are:

  • PI: HDMI
  • PI: Analogue
  • PI: HDMI and Analogue
  • ALSA: Default

Hey, I had an option called “ALSA: Playback/recording through the PulseAudio sound server”, and it worked for me. I picked that option, ran pavucontrol to configure PulseAudio to use Pisound and made sure that jack was not running in the background. The audio seems to work with Kodi this way.

You can install pavucontrol by running:

sudo apt-get install pavucontrol

Here’s a screenshot of the config:

Hope this helps!

1 Like

OK, I’ll try with pavucontrol.


Edit: It worked! Thanks everybody!

1 Like