Pisound (beta ver.) / Pi3 : no power


#1

Hi there

I’ve been using a Pisound (Beta version) on a Pi 2B for a year or so - I even managed to get it running via the Pi’s 5v power, rather than using the power plug on the Pisound, I’m running headless and without anything connected to it so I guess the power req was low enough.

I’d like to start using the Pisound app so need Bluetooth (and Wifi would be good!). I mounted the Pisound on a Pi3 with a clean install of Raspian Stretch and installed the Pisound software. The Pi boots OK, but the Pisound doesn’t show up as a soundcard in the Pisound config - not a big surprise that it didn’t work as its got more to power (wifi + Bluetooth as well as the Pisound). I tried powering via the Pisound power socket using a 12v adaptor from an old Netgear router, but that does the same - Pi boots fine, Pisound doesn’t.

The Pisound still works fine on the Pi2.

Is this a know issue with the beta Pisounds? I don’t think it is! I just wanted to check if anyone had any advice before I spend £10 on a power supply!

self promotion alert I released this recently, the Pisound was used on all of the tracks https://linearobsessional.bandcamp.com/album/puddling :slight_smile:


#2

Hey, the beta Pisounds don’t have a HAT EEPROM chip on them, they are not auto-detected, so you have to add dtoverlay=pisound line in your /boot/config.txt

You may try manually loading the driver by running sudo dtoverlay pisound

If it still does not get recognized, please post the full output of dmesg here.

Congratulations on the album! :slight_smile: Will check it out.


#3

That worked! :slight_smile:

Really enjoying the app, + thanks very much for your help, very much appreciated

Cheers

D