Pisound app module making

Hi Everyone!

I am trying to create a slider on my pisound module that can control the delay of the patch.
Audio is meant to be coming in via adc~ and go through the delay patch. The delay patch was taken from online and works by itself. But when I try to open the Pisound module, it does not open the module.

I have a feeling it has something to do with the sending and receiving within pure data. The "send symbol and “receive symbol” are different when I open my Vslider properties of the delay sliders. In the step by step tutorial it seems like the send and receive symbol are the same. I have attached a picture of the details on my screen whilst making the parameters.

Any help is well appreciated.


Yes, they should be the same name for the application to show when changes are made in the patch.

Also, you have a syntax error in your json, use tools like https://jsonlint.com/ to verify the syntax. Otherwise no controls will show up.

Hey Giedrius,

Thanks for that. I have fixed up the JSON errors. I am trying to understand the Pure Data details I’ve got. I changed the names so the send and recieve symbols are the same but something is still not working out. I might try asking the Pure Data forums as well. If you have any idea about it do let me know!


So just another update on that problem, I have managed to make the actual sliders and they show up on my pisound app. But the ktrl line still indicates . Perhaps something to do with the type of data. I noticed my delay patch is using the $ sign a lot. I checked my JSON file and it is verified too

You shouldn’t use $0 for parameter names you want to use with the App - it gets converted to a unique number within Pure Data, this is useful to avoid conflicts in subpatches. You should use globally accessible identifiers for App controllable parameters in your patches.

1 Like