Pisound app - can't import from USB --> collections


#1

Hi there

So a couple of things!

I’ve been trying to import Pd patches from USB to /usr/local/...-patches and was getting an error cp: cannot overwrite directory ‘usr/local/puredata-patches…’ with non-directory Couldn’t find a way around that (was looking at this), so I added the Pd file to /usr/local/...-patches (logged in via VNC)

But, when I run the app and click ‘Collections’ the Pd patch doesn’t show up. So how do I manually add patches to a collection?

Also - I managed to delete all the example patches! Is there an easy way to get them back again :slight_smile:

Cheers

Dan


#2

I’ve got the Pd patches running from /usr/local/...-patches/[my_folder] via the app :slight_smile:

I copied the .yml from the basic patch in this tutorial:

 name: Basic patch
 author: Giedrius
 entry: basic.pd
 image: basic.jpeg
 description: |
     A demo patch for the controls.
 tags:
     - simple
     - controls
     - demo

and edited it with the details of my patch, then added that to /usr/local/...-patches/[my_folder] and copied the image file from the tutorial there too.

Opened the app, it showed up in collections, and it works fine


#3

Hey!

Could you post a screenshot of the entire error? Is you patch located in a folder with ‘.pd’ at the end of the folder name? If so, that is what could be causing the issue, but to tell more I have to see more information in the error message and what happened just before.

The patches appear based on whether there’s a valid blokas.yml in the patch subfolder, or if there’s a ‘main.pd’ file (legacy support). Any issues with blokas.yml should be reported as an error message in sudo journalctl -u pisound-ctl -f on Pi when refreshing the list using a mobile client.

This can be resolved by doing sudo apt-get install --reinstall pisound-ctl blokas-pd-patches


#4

Great, thanks. I’d missed the folder needed a .pd at the end of the folder name, so that works now. I had to do sudo apt-get install --reinstall pisound-ctl blokas-puredata-patches and that reinstalled the missing patches :slight_smile:

Cheers

Dan


#5

Actually the folders are not required to have .pd at the end of the folder name. If you have a single file pd patch named “patch.pd”, the app expects to find “patch/main.pd” when importing, or “patch/patch.pd” and “patch/blokas.yml” to tell that the entry point pd file is “patch.pd”.