Patchstorage access in Midihub editor


I am running the Midihub editor on OS X 10.12, and can’t seem to access Patchstorage presets. Upon opening the dedicated window or running a search, a loading message appears briefly but nothing shows up, blank always.
I’ve tried reinstalling the editor.

Have you come across this issue before, any tips ?


Hey, it seems to work ok on our devices. Does itself load fine in the browser?

Could you post a screenshot of the Midihub Editor with Patchstorage pane open?

Yes I’ve accessed and downloaded patches from their website, but was hoping for a more practical direct access within the editor.

I’m also running 10.12(.6)

don’t usually keep that pane open, but when I select it it the View menu,

FYI, I get this:

Screen Shot 2023-01-04 at 14.58.52
for a few seconds, then it loads up.

Is yours just blank all the time?

I get the same Loading message briefly, then it goes blank. This happens when opening the pane, as well as when running a search.


FYI, to show activity, that dash after “.com” goes through a cycle (- \ /, maybe) & the load on my slow connection lasts abt 2 secs.

PS. I guess restart Mac didn’t solve?

Yes I also get the - \ / animation.

I’ve had the issue for a while so plenty of restarts haven’t solved it.

back in the day I used to use Applejack to repair permissions. (worked a treat but No longer recommended since Mountain Lion)

Might be worth trying via Terminal MacOS Sierra: How to Repair Permissions - Technipages

Or wait until tomorrow and see what someone with expertise (Giedrius) might recommend!

Thanks, I’ll try that out !

Does the context help work correctly?

Could you open this location in Finder and see if it contains a file called ca-bundle.crt:


You can also right click on the file, and open Quick Look to inspect it a little bit. MacOS does not seem to provide an easy to access verdict whether it’s treated as valid by the OS.

A possible issue with loading might be some issue with the security certificates, if something fails to validate properly when opening the https connection, it wouldn’t be able to load anything. It should report an error though in the pane, it’s odd that it doesn’t give any error.

Yes the context help works fine, giving the proper information when I click on different pipes.

ca-bundle.crt is present at that location.

Could you please run this command in a terminal while Midihub Editor is open, and Patchstorage pane has finished its loading animation:

vmmap -w Midihub > vmmap.txt

It will produce a vmmap.txt file in the current folder (most likely your Home, you can run open . to open the Finder in current location). Please attach the file here or send it to me via a PM.


vmmap.txt (127.4 KB)

Thank you!

An odd thing I observe is that there’s 2 different versions of OpenSSL library (responsible for https connections) loaded in the Editor’s memory which seems wrong:

  • /Applications/Midihub (correct one)
  • /usr/lib/libcrypto.0.9.8.dylib (wrong one)

For the sake of an experiment, could you try temporarily moving out the 0.9.8 lib, and restoring after the experiment?

  1. Quit the Editor completely.
  2. Run sudo mv /usr/lib/libcrypto.0.9.8.dylib .
  3. Run the Editor, check out the PS pane.
  4. Run vmmap -w Midihub > vmmap2.txt to produce a new log for attaching here.
  5. Run sudo mv libcrypto.0.9.8.dylib /usr/lib/libcrypto.0.9.8.dylib to restore original state.

‘operation not permitted’ despite punching in the admin password

Ok, I’ve went through the remaining 2 MacOS computers I have available, they do have the same libcrypto in /usr/lib, and they do load it into memory for Midihub Editor, so this experiment won’t show us anything interresting. works fine on all of them…

Btw, does Help → Check for Updates Now… work without any errors?

Thanks for finding a workaround.

Check for Updates seems to work, it detects the latest version.

I didn’t find the workaround yet, or did PS started working for you? :slight_smile:

Oh no I just meant concerning the test on libcrypto.0.9.8.dylib …