Orac very confused how to launch on Pisound

Raspberry pi 4 8gb
Have Orac 2 v 1.0.2 installed on Pisound with patchbox os 1.1.0-2.

In the Orac 2.0 for Raspberry pi video TheTechnobear explained that Orac will start when raspberry pi is booted (11:14) and that remote services are not started unless I press the button.
This is how I wanted to run Orac direct from the pi. However, I cannot find any explanation in this video.
In the Orac 2.0 getting started video TheTechnobear says at (0:58) “When you start Orac” but already has the PD gui open and doesn’t show how to open this on the pi. Feeling more than a little silly here as I can’t see what I am missing. Cannot see orac as a file to open in PD.

Have tried also to download files from patchstorage.com and install to path /home/patch/media/orac/usermodules. Tried to run these PD patches but still no joy very confused.

Hey, the Pi 4 8GB has a known issue with last Patchbox OS release: Patchbox Gets Corrupted on First Boot (Raspberry Pi 4 8GB)

You have to workaround by running:

sudo apt update
sudo apt install raspberrypi-kernel
sudo apt upgrade
sudo reboot

On very first boot, or on an older Raspberry Pi, if available.

The PD patch running in the videos is this one: https://patchstorage.com/orac-remote-control-patches/

It’s a remote client, you may have to change the IP address to the one the Patchbox OS running with and connect to it. You may use the client on your laptop, or you may run it on the Patchbox OS itself, in that case, use IP

Make sure that you say yes to “Start MEC service now” prompt when activating the ORAC module from patchbox utility.

Hey thanks for your help Giedrius. Is the ip change done from dhccpcd.conf file on patchbox OS?

No, it’s in the PD client patch, you have to edit the text box with the IP (probably you’ll find it containing ‘organelle.local’ or ‘patchbox.local’ values), and hit the Bang box. This is near the ‘edit hostname here ->’ text in the patch.

I’m in! :partying_face:

1 Like

(Solved! See edit.)
Ok, this is probably a very noob question but here we go. I’m in the same situation. I’m trying to edit the hostname in the pd window but I can’t get to edit it.

I’m connected through VNC. I opened the Remote Control pd patch:

As you can see, the box in blue says organelle. I want to edit it to patchbox.local or maybe

What am I missing?

Found it! We need to activate Edit mode. To do so, in the top menu Edit > Edit Mode (or hit Ctrl+E). Then edit the hostname blue box to what you need (in my case Then remember to turn off Edit mode (again: Edit > Edit mode or Ctrl+E). Hit the loadbang button just above the blue box and it should work. Make sure you save the pd patch this one time (later, you don’t save the pd patch, you save your patch changes through Orac)

1 Like