ORAC Pagetitle bug

Hello,
I am experiencing a strange bug with ORAC.
On all my clients, the pagetitle objet has a display lag of 1. In other terms it displays the pagetitle of the previous page I was on.

For example under the Brds Mono module, if I go from the first page which is Oscillator to the second which should be Vca the title remains Oscillator. Then if I continue to the next page which should be Vcf the title displays Vca. The behavior is the same going to the previous pages, the displayed page title is the previously selected one. If I go back all the way to the first page, the displayed title is Vcf for this particular module, even if I activate the Prev button multiple times. It remains stuck on Vcf instead of Oscillator

The Ctrl properties work as intended and display the correct Value and Desc.

The moduletitle and the menudisp also work fine.

If I print the /page OSC message it is exactly what is displayed. So I am suspecting there is something wrong with ORAC and not the clients. Has anyone experienced this bug ?
In which part of the ORAC patch are these pagetitles generated. I can’t seem to find it.

ORAC is running on the latest Patchbox on a PI4 with a Pisound hat.

Ok so I might have a lead on what’s going on. If I re-trigger [pd connect] after I change the page the pagetitle updates correctly.
If I analyse the incoming OSC messages, i get the wrong title when I press Prev or Next Page. But after a reconnect the title is correct in the OSC in.

I tried a quick and dirty fix that re-triggers [pd connect] each time I press Prev or Next. It works with a delay of 0ms and don’t without (weird). But this adds a 1s delay before I get the updated title which makes the menu not responsive at all.

As I don’t understand where the OSC messages are generated in ORAC, I can’t investigate any further. Am I really the only one experiencing this bug ? My patchbox image is the latest and doesn’t have any customisation.

Capture d’écran 2021-02-05 à 19.51.38

Hey, there was an issue introduced recently in the Orac deb packages, please try again after running these commands:

sudo apt update && sudo apt install mec orac

# Just in case restart both services
sudo systemctl restart orac mec
2 Likes

Yes it works with the update !! Thank you so much @Giedrius
And thank you for the great work and reactivity on the forum !

Patchbox OS and the PiSound sure are impressive !!

1 Like

Yes that’s a good fix thank you. And the bonus of having the ‘empty controls’ showing no old labels as you move from page to page, and losing the mysterious ‘Division’ label on the 2nd row.

1 Like