On-board card no sound

#1

Hi. Yesterday I downloaded Patchbox OS to try.
I managed to get sound with a usb card (M-Audio), but not with the Raspberry On-Board.
I can only get audio on the On-Board card if I uninstall PulseAudio.
I’ve mainly tested with Pure Data, but I haven’t been successful with any of the others either.
Any ideas?
Thank you very much.

Edit:
Tested on a Raspberry Pi 3B.

0 Likes

#2

Hi, did you configure the built-in audio card using the recommended settings at https://blokas.io/patchbox-os/docs/GettingStarted/#initial-setup-wizard ?

0 Likes

#3

Yes, 44100, 512 and 3, as recommended.
Jack works fine, but there is no sound unless you remove PulseAudio. Then I have sound using Jack or just ALSA.

0 Likes

#4

What is the Pure Data’s configuration when it’s not working? How does the Jack Client graph look like in Patchage?

0 Likes

#5

The configuration is the same that comes predefined by default with Patchbox.
But I don’t think it’s something related to Pd, because I don’t get sound from any software, not even from the browser testing (for example) YouTube.

0 Likes

#6

In case of using Jack as the backend, you should see all the audio clients in ‘Patchage’ software, check if stuff appears and gets connected together.

0 Likes

#7

Everything seems to be correct, the audio outputs of any program (according to Patchage) are connected to the Patchage’s “system” box, on the playback_1 and playback_2 inputs.
But there is no onboard sound, only usb.
Also tried with qjackctl, different settings, etc…

Edit:
Make it clear that I don’t use both at the same time. Disconnect the usb to test by the onboard card.

0 Likes

#8

I’ve done some tests and checked when switching to a tv with speakers, that the sound only comes out through HDMI.
How can I change it to the 3.5 jack output of the Raspberry?
I tried to force it using raspi-config and from the desktop, directly over the speaker icon. But it always comes out through HDMI.

0 Likes

#9

Check this doc: https://www.raspberrypi.org/documentation/configuration/audio-config.md

0 Likes

#10

Well, first, thank you Giedrius for the help.
I have read and tested the tips given in the link, but I still only have audio through HDMI.
Am I the only one who doesn’t have jack audio on the Raspberry using Patchbox OS?

0 Likes