No sound PureData

I am able to get a simple test mp3 to work, however, nothing I do in PureData outputs. I’ve even tried just an 440 osc hooked to a dac that works on my computer. The light is blinking after loading the patches and there is a PureData process running. Any ideas?

Hey, what do you have in Pure Data’s audio settings? You should make sure that Pisound is selected (usually it appears as hw:1,0)

I checked and I am able to get sound from the pd patch when I open it through the GUI editor, but when I try to use the button, I get nothing. The patch is saved to /usr/local/etc/pisound-patches/main.pd and I have confirmed that it is being picked up by the single button script by adding an echo statement right before the pd command. Pd is running after the script and there apparently is no error, but still, no sound.

Hey, good to know that the sound is working. The arguments used to start Pure Data can be found in /usr/local/etc/pisound/, you may try playing around with them, especially the -D hw:1,0 part. It seems in some circumstances Pisound may get a different number on some systems. I will note this down and release an improvement in future version to detect it automatically.

The line starting Pure Data:

The problem was that PureData is splitting pisound into two devices on my pi: “pisound (hardware)” and “pisound (plug-in)”.

Changing the ‘-audioadddev pisound’ option to ‘audioadddev “pisound (hardware)”’ in’s puredata command fixed it. Thanks for all the help. Love the device so far!