MPC Live 2 blokas arpeggiator

Hi folks,
I’m trying to get set up MPC Live2 with Blokas in an attempted to allow me to use the Qlinks on the MPC to control the values of the arpeggiator in blokas.

I’m doing this as a workaround because I cannot find a way to control MPC’s own internal Arpeggiator using the qlinks…

Could anyone advise the best way to approach this?


From a brief look at the MPC Live2 sockets and this video about Qlinks it looks like it should be a breeze:

  • connect one of the MPC MIDI outs to MH.
  • configure MPC so that it’s sending out CC from that port when you turn a Q-Link.
    Check this with MidiMonitor: Screen Shot 2023-08-07 at 19.32.38
  • Ensure also MPC is sending Clock to Midihub (BPM shouldn’t be 0.0 like in my pic!) – at least when it’s playing (Arp won’t work without it)
  • Now choose which Q-Links you want to control which property in Arpeggiator. Click Map for a property and turn the knob.
    ( MPC will probably also allow you to change the range of a knob so that MH only gets the values you want. You might just not need -7 → +7 Octave Range!)
1 Like

Thanks a mill for getting back,
I have followed what you’ve suggested but I must be missing something
I have MPC out midi going to blokas midi A

Blokas out midi A to MPC in 1 midi
Blokas connected into the laptop to use the midi hub app
Midi hub is receiving clock from MPC
Pipeline is as follows MIDI A in - Arp- MIDI A out
MPC is receiving some clock signal from midi hub
Sequencer on MPC is running with the first step
But no notes or time division being altered from the midi hub arp

Hey, Brian
I see Clock in your MIDI Monitor but no Note messages.
Could it be that your sequence is going out the other MPC port?

Don’t know what “time division being altered” means

some Midihub things to note

When monitoring a working ARP, be aware there’s a slightly confusing foible:

Note here, monitoring ARP pipe…
Screen Shot 2023-08-08 at 09.08.06
…there’s only Timed Note Ons coming out

but monitoring the next pipe…
Screen Shot 2023-08-08 at 09.11.38
…we see the output as it really is.

Note: I’ve changed my Monitor Settings so that I’m not seeing Clock
Screen Shot 2023-08-08 at 09.37.34

I find it useful to have a (temporary) extra Monitoring line
ARPwithExtraMonitorLine.mhp (393 Bytes)
which sends a ‘re-channeled’ copy of the input for comparison:

Now we can see the input notes (remapped to 16) alongside our ARP line notes.

PS. On a Mac, doing shift-cmd-4 will give you a draggable cross-hair to make a screenshot of a selection of your screen.

1 Like

Thank you!

I’m getting there slowly, I’ve got notes coming into midihub now
In my pipeline I have delay and it’s sending to the MPC ok… so that works
However If I remove the delay and put in arp or repeater it doesn’t seem to send anything to MPC
Is there something else missing for arp to work?

Arp and Repeater require MIDI Clock (sync) messages to be going through them, in order to produce output. Does the MPC send the clock to Midihub?

Thanks…yes midihub is receiving clock from MPC

Can you show how the Monitor pane looks like while the Arp or Repeater pipe is selected?

MPC is weird on this. You can’t send out a note and receive that same exact note and play it at the same approximate time. You have to transpose it up or down by 12(or any other semitone). So be aware of this after you get your “MIDI Program” and Qlinks set up properly.

I have a extensive patch using the MPC QLINKS and this has always been annoying but workaroundable. In your midi program on the MPC, transpose the track up or down by an octave and the notes should start sounding.

But I also see that you are not getting CC values at the MIDIHUB. Make sure you are using a midi program. In your picture I don’t see that the arp is mapped to anything. You have to map a parameter to a CC to be able to alter anything.

Post of a pic of your midi program(MPC) settings from the main screen so I can get a better of idea of your routing.