MODEP - Error adding effect

I have my pisound installed and passed tests according to getting started guide. Also had installed Pure Data per instructions and seemed fine. Now I have tried MODEP running the one-step install. I am able to bring up the MODEP Pedalboards that are provided as examples, but if I try to add an effect to an existing board, or to a new blank board, all I get is Error adding effect.

Any suggestions to solve other than restarting from scratch installing the Rasbian lite?



Hey, just adding a link to the same issue reported on GitHub:

@hank, while we are debugging this issue, you can use an already prepared image of MODEP from Cheers!

I had the same problem last night having installed the newly prepared image.

It seems to be a space problem: When you initially write the image to the memory card it doesn’t fill the whole card, just the size of the downloaded image. Once you boot it if you do a:-
sudo raspi-config
under advanced (I think) you have the option to expand the file system to fill the whole memory card. Once I did that it worked OK.



Great you got it working. I know they were working on fixing the issue, maybe they updated the image. On my install, after installing raspberian Jessie, I had expanded the image prior to the manual modep install, so space shouldn’t have been an issue for me. Thanks,


@hank, for the time being just use the prepared MODEP image. :slight_smile:

I installed Modep over a fresh Raspbian lite with my new rt kernel. The modep gui is well launching but none effect is working … same issue as above : error adding effect … Is there a solution, workaround, idea to find this bug and maybe fix it ?