MODEP consistently losing MIDI device connections

Things work for a couple of minutes after boot, but then nada. I have been using (trying to anyhow) Pisound with MODEP as a midi host for an Arturia MicroLab and a couple other things, but even one device connected still does it. I had hoped to use it as a host and also process sound but it’s been so unreliable I have had to resort to using my Axoloti as a single port host. Would very much like to use Pisound to host several devices in a permanent configuration but I am unable to even guess how I would go about doing that. Any advice would be appreciated.

Do you connect the devices together in MOD UI and the connections disappear? Or how does the issue manifest?

Is there any errors logged in dmesg? (run this command in a terminal to see)

I run the device from the virtual port in MODEP to the output to Pisounds MIDI DIN out. Nothing looping back as there is no DIN In connected at all. I have it running headless so I don’t know about dmesg errors. Is there a terminal window available in the MODEP web interface?

Also the whole device just seems to lock up, not just losing MIDI connections. It seems to do it at about 5 minutes after boot, every time.

You may use remote shell client to run commands on the device, see this guide: Raspberry Pi: Remote Control Raspberry Pi via SSH

It must be determined what goes wrong in your case. Just recently another seemingly simillar issue was reported: Upgraded Patchbox, getting system freezes

I wonder if it’s the same issue, may be some updated Raspbian package is causing an issue…

Hardware and software is conspiring to drive me crazy. I just hooked up 2 separate keyboards to my Pi and neither will allow me to type the pipe to dmesg | less. I get a tilde or a number hash symbol. ARGH! I am seriously irritated now. Anyone wanna buy a couple Pisounds and Rpis?

Remote shell (ssh) and VNC Viewer are really convenient tools to manage the RPi from your main laptop, I use that all the time. :slight_smile:

We can go about this another way, could you roughly recall the steps you’ve done to get into the current state? Did you do roughly the following sequence:

  1. Flash Patchbox OS
  2. Go through the wizard
  3. Update the system through the utility
  4. Install MODEP

Did you do some more software installation / updates or configuration?

No additional configs, just updated it again (last time was a few weeks ago.).

So you’ve done sudo apt-get update && sudo apt-get upgrade and it started misbehaving? Or did you pick the update option in the patchbox utility?

Yep, updated it manually not through the wizard.

So only after the most recent update it started freezing? Was it ok before?

I haven’t tested it just now, but it has been misbehaving from the start. Is there some way of just enabling it as a host for several things without using MODEP? I really don’t care so much about effects, but the MIDI hosting is really crucial to my setup.

What do you mean by MIDI hosting? Just routing MIDI data between hardware devices?

If so, you can just use the amidiauto utility (which is already installed and running), you can do:

  1. Deactivate MODEP: patchbox module deactivate
  2. Edit the routings configs: sudo nano /etc/amidiauto.conf, see this post for examples: Midi connection manager, you can see your MIDI device names by running aconnect -l.
  3. Save and close the config file (ctrl+x, y, enter)
  4. Restart amdiaiuto, so it reads the latest config: sudo systemctl restart amidiauto

If you hit any issues, please share the contents of /etc/amidiauto.conf and output of aconnect -l so we can help :slight_smile:

Oh, good. Yes just acting as a way to convert USB only hardware to DIN. I’ll try out the amidiauto later today after I regather my mental fortitude, cuz .conf files and me don’t get on so well these days ( I got sick and almost died, now my brain doesn’t work like it used to.) Sorry for my ineptitude, I used to be a pretty smart guy. Less so these days.

Also thanks for the help, I apparently can’t even remember basic polite etiquette, LOL.