Modep and guitar effects latency


#1

Hi,
I’m exploring Pisound with latest Modep image (2018-09-11) on Raspberry PI 3 B+ as guitar multi-effect processor. I hope I’m wrong but I’m almost convinced that this setup is unusable due to a small but annoying latency that prevents playing smoothly. By default, jack audio daemon is started with the following parameters:
-v -t 2000 -P 75 -d alsa -d hw:pisound -r 48000 -p 128 -n 2 -X seq -s -S.
I tried to decrease dps period to 64 but, as I could expect, this resulted in a lot of crackling. Sincerely I’m not black belt in Jack…can someone suggest me some settings to try? And, I know, this isn’t the right place but is it possible that the Mod Duo suffers the same problem?

Thanks

Edit:
maybe I found the right suggestion searching in the forum. Increasing the sample rate instead changing the dps period could solve the problem.


#2

I successfully use -p 64 with SuperCollider on the Pi, which yields ≈4ms of audio latency, in to out. I imagine the same is achievable with Modep.

Here are some things to try:

  1. Set the cpufreq governor to “performance”:
echo performance | sudo tee /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor
  1. Include -R in the jackd line to make it use realtime scheduling.

  2. The thing about sampling rate is that it needs to be one the Pisound supports directly. 48,000 is the right choice here.

    People see a big win going from 44,100 to 48,000, as using the later former requires upsampling, which is CPU expensive.

    Choosing 96,000 isn’t likely to improve matters: Sure, the latency is half for the same buffer size (128) - but now the software needs to compute twice as many buffers per second. You’d get the same lower latency, with less CPU load, by leaving the sample rate at 48,000, and using a buffer of 64.


#3

Are these settings ( sample rate and cpu bosst )pre configured with the blokas release of modep? I havent been using modep for a while but had considering showcasing to a guitar buddy of mine


#4

Yes, these settings are preconfigured in MODEP, except ‘-R’ flag is not specified for Jack, but Jack attempts to use realtime scheduling by default, so it should work as if ‘-R’ was provided.


#5

Do you mean using the former? Because just before you said that 48,000 is the right choice. Thanks


#6

er, yes, just a typo. should be - using the former


#7

Thanks for clarifying!