MidihubEditor on rpi/arm/debian


I am trying to get MidihubEditor running on an rpi zero w (bullseye) and not having any luck. Downloading the arm AppImage (current, but have also tried a few older versions linked on these forums), chmod, then execute gives:

./MidihubEditor-arm_1.13.4.AppImage: No such file or directory

Is there some system requirement I am missing or anything else I can check? Thanks!

What is the output of:

ls -la MidihubEditor-arm_1.13.4.AppImage

Hi Giedrius,

t******@rpi-uconsole:~/Downloads $ ls -la MidihubEditor-arm_1.13.4.AppImage
-rwxr-xr-x 1 t******* t******* 25018556 Sep 3 16:01 MidihubEditor-arm_1.13.4.AppImage

Did you execute this command from within ~/Downloads?

I did. I also tried with the file in my home directory and executing there.

Please do this:

strace ./MidihubEditor-arm_1.13.4.AppImage 2>&1 > strace.log

and send me the strace.log file it produced.

1 Like

Thanks so much for helping me sort this out! Here is the terminal output, strace.log was created but is empty:

t******@rpi-uconsole:~/Downloads $ strace ./MidihubEditor-arm_1.13.4.AppImage 2>&1 > strace.log
execve(“./MidihubEditor-arm_1.13.4.AppImage”, [“./MidihubEditor-arm_1.13.4.AppIm”…], 0x7ffbdb5db0 /* 47 vars */) = -1 ENOENT (No such file or directory)
strace: exec: No such file or directory
+++ exited with 1 +++

What is the output of these commands:

file MidihubEditor-arm_1.13.4.AppImage

uname -a

t*@rpi-uconsole:~/Downloads $ file MidihubEditor-arm_1.13.4.AppImage
MidihubEditor-arm_1.13.4.AppImage: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 3.2.0, BuildID[sha1]=b0f191c56325e0ef8be4dc6a4fbd3dbca6adfd40, stripped
t*@rpi-uconsole:~/Downloads $ uname -a
Linux rpi-uconsole 5.10.17-v8+ #5 SMP PREEMPT Thu Jun 29 13:36:01 CST 2023 aarch64 GNU/Linux

Ok, the problem seems to be that you’re running on 64 bit arm while the editor is built for 32 bits. Your distribution does not seem to be able to natively support running 32 bit arm applications. You can try doing this:

When making the link in /lib, you may have to use this as the link name: /lib/ld-linux-armhf.so.3 as shown by file output.

Another way could be using qemu.

1 Like

Ok, I will take a look and give this a shot. Thanks!

No luck so far. Trying to run the executable now gives:

t*@rpi-uconsole:~/Downloads $ ./MidihubEditor-arm_1.13.4.AppImage
./MidihubEditor-arm_1.13.4.AppImage: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory

I will look into qemu. Any chance of an arm_aarch64 AppImage? Thanks again for your help!

What is the OS distribution you’re using?

I am on raspberry pi bullseye:

t******@rpi-uconsole:~ $ cat /etc/os-release
PRETTY_NAME=“Debian GNU/Linux 11 (bullseye)”
NAME=“Debian GNU/Linux”
VERSION=“11 (bullseye)”

t******@rpi-uconsole:~ $ hostnamectl
Static hostname: rpi-uconsole
Icon name: computer
Machine ID: c9935527b4f544c1a0553de5a4ba5bd5
Boot ID: 96414b60f68d47aaac65d4f3944ad935
Operating System: Debian GNU/Linux 11 (bullseye)
Kernel: Linux 5.10.17-v8+
Architecture: arm64

t******@rpi-uconsole:~ $ cat /etc/apt/sources.list.d/raspi.list
deb Index of /debian bullseye main
/# Uncomment line below then ‘apt-get update’ to enable ‘apt-get source’
/#deb-src Index of /debian bullseye main

You may try adding arm_64bit=0 to your /boot/config.txt to disable 64 bit mode.