Midihub Won't Work and Won't Connect

Out of nowhere, my Midihub stopped working (not passing any midi signals through) and wont connect to my computer (Mac). When I try to connect, I get two error messages:

  1. Lost connection to Midihub! Sync error 19. (then I click OK, and…)
  2. Downloaded pipeline verification failed! Error -6.
    Please help!

Try switching the preset to another one using the button before connecting, and then try to connect again. If it works, create a memory dump using Device->Export Everything, send it to me so I can see what’s wrong. :slight_smile:

If it doesn’t help, you may have to try to reflash the latest firmware.

Hi Giedrius,
I managed to connect using the method you suggested, but then the same problem happens when I try to switch back to preset 1.
I was able to do the ‘export everything’, but can’t attach it here (unauthorised file type).

Sorry about the upload issue, just fixed it for .mhd files. You may also simply send it to my e-mail giedrius@blokas.io :slight_smile:

I may be able to recover most of your Preset 1 from the memory contents, in the mean time, you may just overwrite another preset on top of it.

Awesome - thank you so much Giedrius.
Here is the file…
Midihub Dump 2020.10.27 05.14.24.mhd (216 Bytes)

Ugh, looks like the preset was not saved in the memory dump, as it was considered corrupted… Do you happen to still have the broken preset 1 in device’s memory?

If not, do you remember what was the last few actions you were doing before the issue showed up? It seems to involve an output pipe.

1 Like

Yes, the broken preset should still be on the device, but I don’t know how to access it.
Before the issue occurred, I was just setting up some simple CC remap pipes.

Ok, I’ll try to make a custom editor version which should be able to download it when exporting everything and send you a PM, please keep the preset there until we get it out, so we can try and take a look to get more information on what went wrong. :slight_smile:

If you have some time and patience for it, you might attempt to figure out how to reproduce the issue (using Preset slot other than 1), if it can get replicated, it should then be easy for us to get to the bottom of it and fix it for good. So far we haven’t seen anything like this before. Knowing how to reproduce it would be really helpful.

1 Like

I wonder if it has anything to do with the USB ports on my computer?
To give you a little more insight, I actually encountered the problem twice - the first time I unplugged the USB from my computer and used a different port, which worked. Then when it happened again, neither ports would work.
Sure, I’ll have a go at reproducing it when I have a chance.