Midihub crashed after trying to update to Firmware1.11.4

Hello there,

my Midihub crashed after upgrading to FW 1.11.4… Now when I restart Midihub all LED’s are lit, and I can’t load anything from the device anymore…


EDIT: I flashed 1.11.3 again and this worked… phew! :relieved:

The bootloader verifies whether the firmware is correctly flashed, if not, then it automatically goes to the bootloader mode, waiting for new firmware to be flashed. What’s the OS you are using? I just tried flashing 1.11.4 firmware downloaded using the same link as posted on the forum, it worked fine.

It should be safe to attempt the firmware upgrade again, try deleting the 1.11.4 .bfw file you had and download it again.

1 Like

Hello Giedrius,

I’m on macOS 10.14.6. Midihub Editor 1.11.2.

I tried to flash 1.11.4 again (after redownloading it) - failed again. Then I tried to reflash 1.11.3 - failed too. All this time I never closed the Editor fully.
So after that,
i) I closed the Editor,
ii) rebooted Midihub in bootloader mode (by holding down the button, while switching power on),
iii) opened the Editor and connected to Midihub.
iv) Then I tried to flash 1.11.4 and
v) it worked!

I guess not-closing the Editor caused the issue in the first place…


Ok, that’s odd, I’ll try to reproduce the issue and will get it fixed. Restarting the editor shouldn’t be necessary. :slight_smile:


I’d just like to add that I received my Midihub today and had similar issues trying to update to the latest firmware. I was using a recently built AMD 3900X PC running Windows 10 Pro 1909. When I went through the update steps the editor was able to erase the flash but then reported an error trying to write the new firmware. The error was something like “lost connection to midihub sync error 1”.

I tried several different USB ports but got the same outcome. Fortunately I was able to use a different PC (Surface Pro 3 running the same version of Windows 10 Pro) and was able to apply the firmware.

Please let me know if you need any more info to help track down the problem (or if it was user error :slightly_smiling_face: ).

1 Like

Can you please PM me the export from ‘System Information’ application, preferably while Midihub is connected? :slight_smile: It will contain all the hardware details that could help us track this down.

Sure. One question though - how do I PM? :blush: I can’t seem to find the option anywhere. I’m wondering if I need to make a certain number of posts before it is allowed…

Could be, I PM’ed you instead. :slight_smile: I had to click on your name, and a popup appears with ‘Message’ button on the top right.

Hi there, I’m in a similar situation to drGrov, just tried updating my new midihub and got the same error message. Managed to load version 1.11.3 ok. Then tried to reload 1.11.4 and failed again. Had to reboot pc to reload 1.11.3 again. My PC is an old core i7 running Win 10 home version 1903.

Hi Greenhorn, what is the error message you are seeing? Please try updating to 1.11.4 a couple of times, it should work in the end. The process itself is safe - the bootloader is located in protected memory region so it can’t be accidentally corrupted.

Hi Giedrius, the error message was “lost connection to midihub sync error 1”, the same as drGrov above. I can confirm that I have now loaded v1.11.4, after changing to a USB2 port directly on my pc. Previously I had been trying through a USB3 hub.

1 Like

Heh - I tried the same (changing from USB3 hub to front panel USB2). However, in my case the Midihub still wouldn’t update…

I’ll add a slightly more detailed message in the next minor editor update that will help us know a bit more about the issue.

1 Like

Hi, same problem here “lost connection to midihub sync error 1”.
lost in bootloader mode…
macOS 10.13.6 (high sierra), tried different fw downloads, ports, cables…

still in bootloader mode :frowning:

Hey, that’s odd, it seems after a few attempts it does work successfully in the end for others.

Please try using the Midihub Flasher tool from this post: [Download] Midihub 1.11.0 Update, let us know how it goes.

Hey, tried the Midihub Flasher tool…
Nah, not working: “Unexpected error occured while flashing the firmware!”

Still in bootloader mode .(
All LED’s are lit.

Ok, we were planning to add more detailed errors around this area, but as it won’t work for you at all, and you have the most consistent reproduction case, we’ll give your case the highest priority and send you some special builds to try out soon. :slight_smile:

1 Like

We have a confirmed fix that improves the stability of firmware flashing, it’ll get released this week. :slight_smile:


Hi everyone,

Just checking in to confirm I am also having this error with my new MIDIHub. Arrived yesterday but currently cannot get past the firmware update stage - tried hherz’s solution above, both 1.11.3 and 1.11.4 releases, rebooting computer and editor, different USB ports, and the Firmware Flasher tool but so far nothing has worked!

Ah - never mind…just got it working somehow!

For anyone else having the same issue, I think hherz’s fix above is closest to the solution. It didn’t work for me the first few times, but eventually something seemed to “click”.

1 Like