Midi output frozen after F0 note pressed

Hi guys,
I use Midihub since 2020.

For some time now, I have been faced with a phenomenon where Midi outputs are freezing.
When I use Midi input B, if I press the F0 key on my keyboard, the Midi output no longer sends a signal.
I can see in my DAW that the following notes entered on the keyboard appear on the Midi In side but nothing comes out on the Midi jack(s).
This malfunction does not appear with another Midi input.

Is there a configuration error on my side or a hardware problem?

Thank you for your comeback.


I have changed midi in and midi out connexions and now I have the same problem when I play E1 note on my keyboard.

Thanks for your help.

Hi, could you try connecting through the Editor and use MIDI Monitor pane to see if there’s any activity going on on the input side, as well as how far it travels through the pipelines?

Could you attach the preset you use here?


Here is the pipeline used (n°3) : FROM MIDI C => TO MIDI B
Using Midi Monitor I can see on the “from MIDI C” input : all the notes I play are ok (the 2 leds are blinking) until I press E2. Then I can see a mapping message and “All notes of on all ch”. The 2 leds are not blinking anymore
After rebooting the midihub module, I can see on the “To MIDI B” output : all the notes I play are ok (the 2 leds are blinking) until I press E2. Then I can see an event message “All notes of on all ch”. The 2 leds are not blinking anymore.

Note that when I press the E2 note, the Midihub interface shows a change in configuration : I can see a new pipeline “FROM MIDIA => TO MIDI B” instead of “FROM MIDI C => TO MIDI B”


Midihub 2024.03.19 21.37.25.mhp (319 Bytes)
Monitoring.zip (833 Bytes)

It looks like you have some undesired mappings on the input pipe’s Source parameter:

Click the U (short for Unmap) button to remove those mappings. Otherwise, whenever you hit the particular notes, the Source parameter will get changed to something else, according to Note Velocity.


I’ve just checked the configuration and I don’t have any mapping.
Is there a way to reset completely the Midihup appliance ?


Here you can find the full export of my config
Midihub Data 2024.03.21 22.40.54.mhd (1.6 KB)

Yes, you do:

In Preset 3 the Source of the Input is mapped to two notes…
…when the velocity of F0 is in range [8,15] the Source will be MIDI-B as the saved preset shows:

Screen Shot 2024-03-21 at 23.23.03

but, as soon as it goes outside this range…

Screen Shot 2024-03-21 at 23.23.16

…the Source will change (here 16 → MIDI-C) to one of the other 16 choices (MIDI A…D, USB A…D, Virtual A…H)…

…so while messages will still come into that physical port, Input MIDI-B is no longer part of your preset so Midihub won’t process them (except as mapping messages)

As @Giedrius says, unless this is behaviour you want, delete the mappings, store the preset and you’ll be fine.


PS. I added an extra MIDI-B as a port to Monitor the incoming mapping while watching the effect on Pipeline 1. If I hadn’t, the cause of the effect would be invisible to us.

1 Like

To identify mappings, look for pipes marked with a green rectangle at the top right. To remove the mappings, select the pipe and expand the > symbol to the left of the property to see the existing mappings.

The screenshot with mappings I posted is from the .mhp file that you posted earlier.

If you see a different view, please post a screenshot of the entire editor with the current preset open and the input pipe selected.

1 Like

I’ve found ! :slight_smile:
Since I only use the Midihub to connect my Midi keyboards together, I didn’t think I had “created” this configuration.

Thank you all for your efficient and quick help.