MIDI clock seems not working

I want to have a MIDI synced delay with MODEP. It seems like there’s only one effect available (Bollie Delay), is this right?

I tried to sync it with my hardware by connecting a generic “USB cable interface” to my RasPi. The interface is recognized properly but the displayed BPM doesn’t change.

The interface is working correctly and I can see the clock with jack_midi_dump. There’s no dedicated MIDI port for the effect exposed in Jack. I don’t know if this is correct. I also tried the MIDI clock effect but the global tempo isn’t changed either. The MIDI clock exposes a port in Jack but it’s not connected to the desired input. Doing so has no effect on the displayed BPM and there’s no clock emitted on the output.

Do you have any idea what’s going on? Is it a MODEP specific issue?

Bollie Delay uses tap tempo mechanism for setting the BPM, it does not make use of MIDI data at all, see https://github.com/MrBollie/bolliedelay.lv2 for more information.

You may install and use any lv2 plugin you like if you put it in /usr/modep/lv2, if you can find a delay plugin that supports MIDI sync, it will work. The UI will be default one, but you’ll be able to access all parameters through the plugins settings menu.

Ok then the GUI for the plugin is either misleading or there’s some customization from Mod Devices?
image

And what do you think about the MIDI clock effect? This should be working, right?

Thanks! This sounds very exiting, gonna try this now.

You’re right, turns out it does support MIDI sync from external MIDI, I didn’t notice this control before. :slight_smile:

At the moment it’s not available to be enabled in the UI, we’ll fix that, in the mean time, you may switch the mode by hand:

sudo nano /var/modep/profile5.json

Edit transportSource line so it looks like this:

    "transportSource": 1,

Save the file, restart MODEP:

sudo systemctl stop jack
sudo systemctl start modep-mod-ui

Then it will be listening to external BPM.

1 Like

Ok the MIDI flow is working now! But the Bollie Delay seems buggy, it just doesn’t emit any sound when it’s sync source is set to internal. But that’s not of your business :slight_smile:

The lv2 installation is working as well. Sweeet! Tried the LSP collection but this is quite heavy stuff. Now I’m crawling for interesting things :grin:

2 Likes

Ok looks like this was a lie :stuck_out_tongue:
I just talked to the Mod guys and it seems that they’re using a different version of the delay.

The fix is not on the master branch: https://github.com/MrBollie/bolliedelay.lv2/tree/fractional

Ok, I’ve just released an updated version of modep-mod-ui and bolliedelay plugin. Get the update by running:

sudo apt update
sudo apt install modep